0

Using Samsung S4, Android 5.0.1, not rooted. Recently I have found at least two websites that the Chrome browser on Android 5.0.1 reports https is not secure. This is because the phone does not have the root CA cert required installed. I know how to load individual CA certificate pem files into the user list using the Security menu and "Install from device storage". I wanted to load all the current ones. I had to get "SectigoRSADVBundle.pem" from Sectigo.com as this CA is used by one of the local government websites which must be newer than Oreo release but and the other pem I found in the Oreo pem files

I tried concatenating more than one pem file but it only loads the first entry in file. I tried making a pem file using the Oreo pem files so it had this layout:

-----BEGIN CERTIFICATE-----
...
-----END CERTIFICATE-----
-----BEGIN CERTIFICATE-----
...
-----END CERTIFICATE-----

but only the first pem is loaded. I most likely do not need all of them but I have no idea which files are newer than my Android built in system list.

Is there a list of new CA created since Android 5.0.1 (or a way to build the list) if I have to load them individually?

There are 137 pem files is there a way to load all CA certs using just one file?

Whenever you put a cert in User Certificates section when the phone reboots the is a warning message, so my next task will be investigating moving it to system list

2
  • Have you considered to just install LineageOS? The S4 is still supported and you would get a recent Android version with CA certs preinstalled. You can install e.g. stable LineageOS 16 download.lineageos.org/jfltexx
    – Robert
    Aug 25 '20 at 18:56
  • @Robert maybe when I sort some other unrelated issues. I was just reading the installation instructions I found no mention of how to restore system back if LineageOS is missing a feature I need (eg sms scheduling).
    – Scott R
    Aug 25 '20 at 20:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.