I've originally asked this question on stackoverflow, and I was suggested to ask it here.

I'm currently in trouble with my samsung Galaxy Tab GT-P1000L GSM+WiFi model from Brazilian's Vivo carrier.

The problem was: Whenever I try to open most apps (Facebook, Twitter, Instagram, and others -- but not all) the Tablet would vibrace once, then twice, then display an error message saying that the "application stopped suddenly" and I'd have to try again.

I've noticed that there were a bunch of apps installed and I deleted them all. After reboot, they came back. If I install any new apps, they would work (even Facebook), but after reset, they were all wiped out and replaced with the previous versions (like it was restoring an old "backup" of the system with those apps installed).

I've managed to use adb to see the filesystem and deleted the contents of "/sdcard" which was mounted like:

/dev/block/vold/179:1 /mnt/sdcard vfat rw,dirsync,nosuid,nodev,noexec,relatime,uid=1000,gid=1015,fmask=0002,dmask=0002,allow_utime=0020,codepage=cp437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro 0 0

/sdcard was a symlink to /mnt/sdcard. Note that there was no sdcard on the device. When one was put, a directory "external_sd" was created inside /mnt/sdcard and the contents of the disc would be there.

I've tried to manually delete everything inside /mnt/sdcard but it all came back upon reboot. (Note: I don't have root access to the device.)

I've managed to mess things up for good when I tried the command ./fastboot erase recovery. Now the main interface keeps "rebooting" -- it displays the carrier name, then the lock screen, then vibrates once, then twice, then carrier name again...

It is running android 2.2 and I'm trying to prep it to give it away (my wife is trading it for an iPad), so, I'm trying to restore everything back to where it was when I purchased it. I can't seem to find a firmware file to download (other than Cyanogen).

Samsung's Kies app (I'm using a Mac) can't seem to detect the device (with USB debugging mode off, it doesnt even try. When on, it says that it can't recognize the device).

Any help is appreciated. Thanks!

1 Answer 1


Download the firmware from: http://hotfile.com/dl/146491093/3b7d6c9/P1000LVIJR2_P1000LZVVJR3_ZVV.zip.html or www.sammobile.com

After that follow this "how to" to install the new firmware:


Make Preparation before flashing:
- Back-up all important data stored in your device (this is important to keep all your data in safe, if something went wrong)
- Ensure that the battery is fully charge (power lose may interupt the process and might brick the device in no time)
- Galaxy Tab USB cable wire – a good conditioned USB wire.
- A PC/laptop with working USB port that runs in Windows OS, this will not work on Mac users)
- Install Kies on your PC just to get the driver of the TAb, or grab the driver.
- Disable any antivirus program, and also Kies if you have it installed.

Download tools and stock ROM:
Odin Downloader with pit and Driver for Galaxy Tab Stock ROMs:
Choose the right P1000XWJQ8 stock Firmware according to your country or carrier providers. The build number is the same on each packages but varies with different CSC file on each specific countries, so you should choose the right firmware for your device to avoid any functionality issues. These stock ROM’s can be found in at sammobile.

Odin Flashing Procedure
1) Once you downloaded the right stock firmware for you device, extract it using winrar, 7zip or any other program to have the single .tar.md5 file.
2) Run Odin on your desktop.
3) Check the PDA checkbox and tick the PDA button and then load the extracted P1000XWJQ8_P1000XXJPZ_P1000DBTJQ1_HOME.tar.md5. (No pit repartition necessary if you have your device runs in original firmware) (Pit file is only needed for advacne users who installed their device with any custom ROMs and getting an error flashing official firmware. Grab the Pit file here, if you needed it)
4) Ensure that the “REPARTION” checkbox mark empty, just only the Auto Reboot and F. Reset Time remains to be checked.
5) Set the Galaxy Tab into download mode – Turn it Off first then gently Press and Hold the Volume Down And Power Button together at the same time.
6) Once the tab displays in download mode screen, connect the USB cable. Check Odin if the ID:COM turns in yellow color and message say ‘Added!’ (it means that the device is properly connected and already recognized with Odin)
7) Hit the “START” button to begin flashing or installing the firmware. DO NOT TOUCH the phone while in flashing process, just wait until it completely finishes.
8.) A word “PASS” on Odin window will then appear as if the flashing succefully done. Wait until the tablet completly reboots., before removing the USB cable.

Do a factory reset, *2767*3855# to regain a full fresh firmware installed. Then confirm the newly installed firmware *#1234#.
That’s it..

  • Tried with Heimdall (on my Mac) and it didnt work (the firmware is updated, but the old data is still there, and the crashing is still happeninig). I'll try with Odin once I get to a Windows desktop. May 14, 2012 at 10:57
  • You can try to flash with VirtualBox's USB pass-through by installing VirtualBox Extension Pack, give it a try! Apr 30, 2014 at 14:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .