4

Is there a problem with, or something missing from, the steps at this guide for installing Magisk on Android 11?

Specifically, in step 13, it says to flash the patched boot image (patched by Magisk Manager) to the phone, with

fastboot flash boot patched_magisk.img

followed by

fastboot reboot

And then to verify root in step 14 by checking in the Magisk Manager app. But doesn't step 13 reset the phone, so the installed apps like Magisk Manager are also gone?

2
  • 1
    unless you set preserve force encryption in advanced settings (before patching) step 13 does break encryption, therefore you are right userdata partition must formatted in order to work unencrypted on next boot. that is in fact a factory reset and the reason why magisk manager must installed twice. But repeating every step is unnecessary, once the boot.img is flashed your device is rooted. the tutorial has mentioned in step 6 'leave both "Preserve" options enabled' (you probably overlooked)
    – alecxs
    Aug 28 '20 at 10:10
  • 2
    Thanks @alecxs ; I'm not sure if this was the reason in my case, as I am 99% sure I left the Preserve option enabled (the version of magisk manager I was using only had one preserve option, which is for force encryption). Also, after step 13 (the first time), with adb shell, I couldn't "su", it seemed like non-rooted. Anyway, then the 2nd time I did retry from step 6, but the patched image ended up being the same as the one from the 1st time (diff showed no difference), so I thought maybe I somehow messed up in the flashing step, Somehow, flashing the same patched image the 2nd time worked. Aug 28 '20 at 11:00
3

Certainly not. It's safe

All that you are doing in this step is to

  • Check if your device is recognized in fastboot mode by fastboot devices

  • Replace the boot image by the patched boot image on your computer by fastboot flash boot xxx.img.

  • fastboot reboot will boot you into OS where you can verify root as next step recommends.

This the normal way of rooting using patched images and will not affect your installed apps. See Magisk official documentation

1
  • 2
    Thanks, I think I did something wrong the first time. When I tried it again a second time, it was working as expected. Aug 28 '20 at 3:59
1

Pixel 3a XL Android 11

Slight problem. Root is enabled first boot into OS, but does not stay after reboot. Have to fastboot boot magisk_patched.img again to enable root. This was done with Magisk Canary.

9
  • Did you try again? For me, it worked the second time. Sep 19 '20 at 13:25
  • Thanks, yes, at least 6 times. Thinking about flashing Android 10, rooting and then OTA 11 install without reboot, Magisk patch and reboot into 11.
    – blueswerks
    Sep 19 '20 at 20:36
  • I found the issue. Slight syntax error. "fastboot flash boot magisk_patched.img" was missing the "flash" command. Now the error is "writing 'boot'... FAILED (remote: Failed to write to partition Not Found)"
    – blueswerks
    Sep 20 '20 at 3:32
  • Hmm .. fastboot devices shows your Pixel 3a XL? (so it is in bootloader mode?) Not sure why else it might give such an error. Sep 20 '20 at 4:16
  • 2
    Solved! Long story short, Xubuntu 16.04 LTS fastboot version does not support the commands needed for Android.. I found the version needed at Highonandroid.com. He has a fastboot.zip with Linux, Mac and Windows versions in the file. Thanks for your support:)
    – blueswerks
    Sep 21 '20 at 8:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.