1

My phone is less then a year old and I had my Screen replaced by Samsung about 2 months ago.(they also changed the battery and aluminium body).So the battery is almost new. About a week ago something happened to my phone while i was using google maps and and it started daring battery at extremely high rate. it's was using almost 20% battery per hour with no use at all and it was getting hot while idling. Since like 4 days ago phone wouldn't even charge to 100%, it would get stuck at 70-80% because it was discharging faster then it could charge.(maybe it was getting too hot and stop charging). I had to revoke alot of location related permissions to slow the discharge to get battery to 100%. It's not as bad as before but it's still completely discharging from 100% to 0% is less then 10 hours with no use at all. It used to last almost 2 days with quite high usage before this bug.

here's what I tried so far.

  • restarted the phone,
  • put every app to sleep and deep-sleep,
  • disabled allow location to apps even when location is turned off (same for Bluetooth and wifi)
  • turned off Bluetooth and wifi scanning even when they are turned off
  • disable the google app and google play services app.
  • did a settings reset.
  • factory(data) reset the phone.

non of this fixed the issue. Even put the phone on medium and maximum power saving and the did nothing, discharge rate is still exact same about 10% per hour while idling.

I took a few bugreports and viewed them in battery historian (online version). I don't know what I should be looking for. Is it safe to post bugreport file here, i don't know what kind of info is in it.

4
  • I would suspect a hardware problem causing an electrical short causing a battery drain. Could have happened when the battery /body was charged without proper care, water or fluid causing short, some burnt out diode on any of the boards ; reasons could be many //get it checked out by authorized people //You did ask that is possible including factory reset
    – beeshyams
    Sep 3 '20 at 7:15
  • it worked completely fine for over 2 months after repair, and repair was done by Samsung under warranty. Sep 3 '20 at 17:38
  • sounds like a weak usb connector to me and it's not really charging. how is battery drain while in recovery or odin mode compared to system mode? Why don't you claim under warranty of warranty?
    – alecxs
    Sep 3 '20 at 19:07
  • Haven't tested it in odin or safe mode. there's only a few Samsung repair centers in UK, closes to me is 2 hours away. So i have to send the device through mail and whole process usually takes over two weeks but because of COVID-19 it can take even longer. Sep 3 '20 at 19:13
0

Sent it to Samsung for repair and they changed the whole motherboard. it took over two weeks for repair because they didn't had the motherboards at the repair center. The issue was mostly due to the bad repair they did when they changed the screen battery and the body.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.