1

I bought an Ulefone Paris 2015 Chinese phone, a few years ago, it came with a bloated/malware OS, I put in a Lexar SD card, formatted as internal, something didn't work right (I don't remember), I tried again with another Lexar but same card, also the same, I stopped doing that.

Since then the cards have been read only and I have thrown everything I can at them to format, except Linux command line, because I'm on Windows and Mac, but always gives errors and that it's read only (it's not plugged on my mac from a SD adapter so there is no lock switch, it's coming from a USB adapter that came with the card).

I rooted the phone and put on a normal android 6.0 and it doesn't format the phone anymore either, they were brand-new cards, but something messed them up from that phone in its original state.

Is there anything I can try before I throw them out? They mount fine and show android files, which pop back up when I delete, because read only, but that original garbage android formatted them in a messed up way, so that's the key, something with Android.

4
  • As the cards were brand new it could be that they were simply forged (claimed to have more capacity than flash chips inside, such forged cards are very common). Therefore before using any bought sd-card you should always test them using a software like "h2testw" which writes the complete sd-card and then checks if the card is able to read everything correctly. Do the sd-cards show up e.g. in disc manager of Windows or MacOS? Also try different sd-card adapters.
    – Robert
    Sep 10 '20 at 16:13
  • I'm pretty sure they were legit lexar 128gb cards, came in proper package and with a little usb dongle you could put card into, a fake wouldn't put so much work into them, also, they show up, mounted, in mac and in disk manager, but if I try to format or verify in mac disk utility I get error code 8 (read only), I tried command line, I can't do anything with them except view the contents of the drive (what was on my phone at the time).
    – GGarrett2
    Sep 10 '20 at 16:21
  • it's a very common problem it seems, read only cards, many posts online, I tried many solutions and they didn't work, I will check out your relevant links alecxs, looks like I may have to set up a linux vm.
    – GGarrett2
    Sep 10 '20 at 17:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.