According to HTC, my Amaze 4G is fully ready from the factory to be queried for its identifier tolken, but when I run the appropriate command, it doesn't work. I get:

$ fastboot oem get_identifier_token
(bootloader) [ERR] Command error !!!
OKAY [  0.010s]
finished. total time: 0.010s

Note that someone reported the same problem, but their phone requires updating firmware and running "RUU". You can read about that here.

Same problem, different cause. Note that I did update the SDK prior to trying run fastboot - I wonder if I shouldn't have!

It's worth mentioning that I called HTC and asked for help and they were of no particular assistance; "You know more about it than I do." "How do I report a bug on fastboot?" (No useful reply to that!)


Well, when HTC leaves it up to us, it's up to us, so I kept playing with it.

It turns out that the response I got is a generic response from fastboot: It does a piss-poor job of checking its arguments. That particular response, in effect, means, "invalid command arguments."

Yes, I made a typographical error and this was the result. It didn't occur to me this could be the case first because MOST programmers check the input before continuing on and give reasonable error messages, and secondly because I tried it first as a dry-run and it gave the response, < waiting for device >. Then, when I did it "for real", I merely hit up-arrow and plugged in the device, etc.

Rather than delete this question, I'm leaving this here as a bread-crumb for others who may run into this same problem. Type it properly and it works! If you appreciate that, vote it up! -smile-

|improve this answer|||||
  • 1
    i copy&pasted from their website and get the same error. what was your typo? – mikezter Nov 1 '12 at 20:43
  • Exact same issue and you were right. I just copied and pasted from the site and it fixed it, thanks! – Nils_e Apr 15 '14 at 20:12

I got this error, solved it thanks to this thread


Basically, this page http://www.htcdev.com/bootloader/ruu-downloads

is slightly misleading. If your device isn't listed, you might still need to update the RUU anyway.

|improve this answer|||||

Not the answer you're looking for? Browse other questions tagged or ask your own question.