fastboot version 30.0.4-6686687

Trying to temporarily boot TWRP recovery image twrp-3.4.0-0-lake.img on my unlocked Motorola Moto G7 Plus.

Phone is connected via USB Type-C to Type-C cord from the box to my laptop running Linux (Manjaro 20.0.3) Live USB system.

When I run ./fastboot boot twrp-3.4.0-0-lake.img or ./fastboot boot boot.img (same file, renamed) with and without sudo, it always gets stuck at Sending 'boot.img' (30080 KB) doing nothing.

Bootloader logs section of fastboot mode shows cmd: download:01d60000.

The PC I use now is the only PC that helped me to actually unlock the bootloader. Other PCs I have were not able to send correct fastboot commands (for example, oem help transformed to oem helpersion, and oem get_unlock_data cut to oem get_unlock). Those PCs had regular USB Type-A 3.0 ports, so I connected them to my phone with corresponding 3rd-party cable. It might be of insufficient quality though.

All files are located near to the root of extrenal SSD connected to another Type-C port, so the absolute paths to TWRP image and fastboot executable should not be too long.

Type-C cords are new and OK.

Motorola doesn't distribute Linux drivers for their devices.

What else could be wrong here? Please help. Any advice is appreciated.

Will update this post later with my own findings as well for people who could stumble a similar problem.

Update 1

Tried fastboot boot boot.img on another PC. It is also running Linux (Ubuntu 20.04). Connection is from Type-A to Type-C. Wire is good. No noticeable changes. Main issue persists.

Update 2

Was able to perform fastboot.exe boot boot.img on another PC under Windows 10. Don't know why it worked. Specs are different than laptops', but cable is the same. Might be a driver issue.

2 Answers 2


SOLUTION: connect the phone using a USB hub (even same port) :P

...worked for me.

Source: https://forum.xda-developers.com/t/yet-again-fastboot-is-stuck-on-sending-boot-img.4166479/post-86491327

  • 1
    Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Jan 10, 2023 at 8:37

An updated version of platform-tools works fine. Perhaps this was a bug.

To get latest platform-tools you can:

  • git clone --branch sdk-release --single-branch https://android.googlesource.com/platform/bootable/recovery and build it;
    • Check this repo for some building instructions;
  • Download pre-built binary executables at releases page;
  • Update package with your distro's package manager:
    • Ubuntu-based: apt upgrade android-sdk-platform-tools
    • Arch-based: pacman -S android-tools

Note: keep your system up to date too! USB drivers & other system parts could affect functionality of this case.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .