1

I have tried going through many reference links for my below issue, but all of them are at least the pre-Marshmallow age so couldn't find a proper solution.

I have a Redmi 2 Prime mobile (2014 model) and I have flashed it with LineageOS 17.1 version (Android 10) (exact version is lineage-17.1-20200711-nightly-wt88047-signed.zip) along with OpenGApps pico version (open_gapps-arm-10.0-pico-20200725.zip).

The device came up fine, most other things which I have checked also is working fine, except for Indic language support. I am specifically looking for Malayalam (South Indian language).

When I try to add it in languages section, it shows the name of language itself as garbage (see item 2 in screenshot).

I tried adding GBoard and Google Indic keyboard, but when I select Malayalam->English, it says 'Your device does not support this language' (can be seen above the space bar of keyboard).

When I add Malayalam language (by typing in English and selecting the only option that comes), Google Play services is shown to check for some language support online but quickly stops and nothing happens.

I checked accessing a web page in this language in Google Chrome and it rendered nicely. But when I checked Malayalam version of Wikipedia, it is the same junk (both in Wikipedia and the Google search results for it)

Could someone help me with what I should try to get this fixed

0
1

At last I was able to add support for the language[Answering for the sake of others who might face this issue]. It seems there was some issue with the font I tried earlier( though it was looking fine in PC and was known to be working in other models of mobiles ). Steps followed

  1. Downloaded relevant ttf and otf fonts to SD card
  2. Rebooted to TWRP
  3. Mount->Select System & External SD->Uncheck 'Mount read-only'->Select 'Internal Storage' for mount location
  4. Press Home( not Back ). Clieck ADvanced->Terminal
  5. In terminal, copy the fonts to /system/fonts/ using cp command ( The copy in Advanced->File Manager also might work, but I havent tried )
  6. Mount->UnSelect System & External SD->Uncheck 'Mount read-only'->Select 'Internal Storage' for mount location
  7. Reboot to system
  8. Verify if font support is available by going to Settings->Language ( or browsing to a webpage with that language )

Many thanks for the support and the initial hint that this might be a font problem @Andrew

1

NOTE: This solution works for all the devices that have font issues.

Your problem can be solved so easily, let me give it step by step.

  1. (Phone) - go to the recovery mode, select Advance Option and tick the SYSTEM alone. NOTE: unselect data and cache for now.
  2. go to this link, download and extract on desktop. Inside this navigate to fast-boot folder. Now get inside the fast-boot folder press(SHIFT + RIGHT CLICK in mouse) and choose open cmd window here.
  3. Connect the phone to a laptop and enter the cmd> adb devices
  4. You'll find all the attached devices.
  5. In cmd give this code : adb push fonts /system/fonts and press enter
  6. Please press home button in TWRP > click Advance Option > now check (Data and Cache) and unselect system - IF NOT YOU WILL STUCK IN BOOTLOOP.
  7. Reboot the device and navigate to browser and see the magic

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.