1

Back in 2015, I rooted my HTC One M7. It was an adventure; I messed up along the way, soft-bricking my phone. Eventually, though, I managed to get it working again. That was five years ago. So, I might as well have never tried to root a phone, because I've now soft bricked my Nexus 6P—and I don't know how to bring it back to working order. I seem to only ever know just enough to be dangerous.

On the Nexus 6P, the problem is that the phone hangs on the Google logo screen. However, I can boot into the bootloader and get into recovery. I've got TWRP 3.4.0.0 already flashed.

ADB does not recognize the device in the bootloader. It only recognizes the device when it is in TWRP. I am using PowerShell in Windows 10 as my terminal.

Everything went bad when tried to flash SuperSU-v2.82-201705271822. While I had done a factory reset before attempting this, the phone only reset to Android 8.1.0, the earliest build of which was 12-2018. Since the SuperSU I attempted to flash looks to have been from 05-2017 ... well ... my bad. Clearly. Rookie mistake.

This seems fixable, though. I just don't know how to fix it.

My error appears to have blitzed my OS entirely. In TWRP, if I look at the 'sdcard' partition, the only directory is TWRP. None of the Android file folders are there (Downloads, Pictures, etc.). Yet, at the level where 'sdcard' is listed, all the system directories seem to be intact.

Further, if I run 'adb shell su' in PowerShell, I get "su: not found", so my root attempt obviously failed.

In sum:

  • I have an unlocked bootloader
  • Device unrecognized by ADB except in TWRP recovery
  • I am not root
  • I seem to have no OS (but the directory structure above the 'sdcard' level seems intact)

I tried sideloading a factory *.zip from Google, but I can't do it from PowerShell with the phone unrecognized by ADB. I then tried using the TWRP ADB sideload option, but was told that my *.zip was invalid when I tried it (should I not have tried flashing the whole angler-[etc].zip?).

On XDA, I'm finding a lot of information, but it's not been helpful to me. This seems like a simple issue with a simple solution, but it's one of those "clear only if learned" scenarios, and I haven't learned.

As such, I just need some hand-holding for how to get back to a working OS. It seems that, for things being bad, they're not really that bad. If I just knew what to do and how to do it, I could get out of this pickle. If someone could teach me how to get out of this mess, I'd appreciate it.

Thanks.

0

I don't have a full answer for you Ican only help with the issue of your device not being recognized. But since I can't comment I will answer instead.

For your problem with your PC not recognizing your device. When your device is in fastboot mode, and connected to your PC. Goto device manager, there should be an item that matches your device that has a yellow mark showing it needs attention. Update the driver for that item and select the adb driver this should make your PC recognize your device. This assumes you have the adb drivers installed on tour PC.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.