I have an encrypted android running LineageOS 15. When it said that there was an OTA update, I choose to download and install this new update. In the first moment it seemed to be alright but when the phone restarted itself the recovery (TWRP) appeared again... and again...

It is in a bootloop mode and there is nothing I can do without loss my data and I can't do nothing to copy my date due to the full disk encryption.

The encryption was made, I think, with the fingerprint and even if it was done with a password I cannot decrypt the entire disk (with the command adb shell twrp decrypt) because my TWRP version doesn't support the decryption.

  • As you TWRP installed you can simply download and install an older version of LineageOS and check if it solves the bootloop.
    – Robert
    Sep 24, 2020 at 7:28
  • I think the bootloop was caused by the full disc encryption... since my twrp version (for huawei p8 lite 2017) doesn't support decryption, neither with the last version it can't read the system and data partitions
    – Bob91
    Sep 25, 2020 at 16:17

3 Answers 3


I had same problem and I'll write tips how i fixed this situation.

You can fix it by just dirty-flash any rom.

Flash any rom by using external storage or by adb sideload(Advanced -> ADB Sideload -> Run "adb sideload ROM-FILENAME.zip") You will see lock screen after reboot.After login,you can decrypt data in TWRP.

If you see some error/crash after android bootup due to dirty-flash,install magisk and create backup by Migrate and restore it after clear data.

  • 1
    This can get complicated easily. Dirty flashing was alright before encryption became a common thing. Since encryption became common dirty flashing can easily result in a failed boot (past experience with a Redmi and a OnePlus device). So we have a situation where a successful boot is already failing, and dirty flash solved nothing. The easiest thing to do is to somehow get a encryption-supported recovery to boot, decrypt data, extract it into PC, and reset data partition.
    – Firelord
    Sep 30, 2021 at 6:20
  • 1
    I fixed my encrypted Redmi Note8(MIUI) by this method.TWRP(and other recoveries too) couldn't decrypt data and no backup.Then I dirty-flashed Custom ROM(Treble GSI) and boot it up.After first login,I succesed to restore my data again.
    – user33004
    Oct 1, 2021 at 8:04

Hey you could have downloaded the lower version of twrp. My phone also went into bootloop when i flashed twrp version 3 but when i flashed version 2 it worked perfectly. But anyway since you have found the solution ,to anyone who reads this answer you must first flash lower versions of twrp.

  • I tried with the last one and it didn't work.... How could it work with a older one ? The issue was that the entire disk was encrypted, system and data partions as well... And, in my opinion, installing the new versione of Lineage wasn't possible because it can't read the files, unless you decrypt the phone (from android's settings) before flash the update...
    – Bob91
    Sep 25, 2020 at 16:13

Searching a lot over the web I saw this question and by reading the entire post, and in particularly this answer https://android.stackexchange.com/a/176124/77853 I brought back my phone to life and without losing anything !

What I had to do was (as suggested in the answer) repair the /data partition plus the /system partition !

  • (FDE) full disk encryption does not encrypt any other partitions than userdata partition. (TWRP > Wipe > Advance Wipe > Data > Repair File System) cannot fix anything on encrypted partition and is strongly not recommend for userdata (except you are fine with data loss) - in fact it only can work on /system because system partition is not encrypted at all
    – alecxs
    Nov 21, 2021 at 8:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .