0

I'm using weechat-android that I installed using f-droid and trying to connect to freenode in order to join an irc server. I am able to connect freenode on my Windows 10 PC using mIRC as expected. Not able to do so on Android after following this doc https://freenode.net/kb/answer/chat.

This is the exact setup I used when I get the protocol error.

enter image description here enter image description here

This is the exact setup I used when I get the failed to connect error.

enter image description here enter image description here

17
  • Where do you got the information about the server `freenode.net:8001 from? When I search for freenode I only get irc.freenode.net:8001 or chat.freenode.net:6697 for the SASL connection. – Robert Sep 30 '20 at 7:02
  • I must have mixed those up I got some of that information from this kb article about connecting to freenode, but wasn't sure about the ports. – greg Sep 30 '20 at 7:10
  • When I set my relay password, relay port to 8001 and host to irc.freenode.net:8001 I still get a Error: Protocol error message. – greg Sep 30 '20 at 7:13
  • I assume you have to use one of the TLS ports, not the insecure plain text ports. – Robert Sep 30 '20 at 7:14
  • 1
    You have to execute these commands in the Weechat program on your PC/server. – Robert Sep 30 '20 at 8:09
1

Note: According to the Quickstart guide Weechat-Android is not a chat-program, it is only a UI for a chat program running on your server:

Weechat-Android is a relay client, that is it's not a standalone client, but one that connects to your copy of WeeChat running on your server. You can connect the two in a number of ways, listed below.

Therefore if you just install the app on your phone it is not usable. You still need an own server on the Internet where your Weechat program is executed.

You can connect to freenode by pointing your IRC client at chat.freenode.net on ports 6665-6667 and 8000-8002 for plain-text connections, or ports 6697, 7000 and 7070 for TLS-encrypted connections. Connect to chat.freenode.net

https://freenode.net/kb/answer/chat

Alternatively there is a Weechat how-to for setting the correct server: https://freenode.net/kb/answer/weechat

/server add freenode chat.freenode.net/6697 -ssl
/set irc.server.freenode.sasl_mechanism PLAIN
/set irc.server.freenode.sasl_username <nickname>
/set irc.server.freenode.sasl_password <password>
/save

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.