1
Asus ROG 2 Phone
17.0240.2009.49
Not Rooted
Happens All the time
Wifi Connection in my home

Ever since updating to 17.0240.2009.49, my phone has been listing one of my wifi connections as "Limited"

But today, it now prompts to "Sign in to Wi-Fi network"

I have no captive portal on this network.

My laptop (windows 10 pro) connects without any problems or prompt.

My tablet (Nexus 9) connects without any problems or prompt.

If I tap to sign in, I am shown a blank page.

If I select "Use this network as-is" in the 3 dots menu, it works for a few minutes and then puts an X on the Wifi Icon saying "no connection" - even though I was browsing web pages before then.

After that, I can't access anything.

I have tried:

static/dhcp - no change
Treat as Unmetered - no change
Rebooted - no change
Reset Wifi - no change
Dynamic/Static Mac address - no change
Rebooted the router - no change
looked through pfSense logs - no information

Any ideas?


Update:

After selecting "Use this network as-is", it shows connected for a bit, then shows disconnected with an X in the Wifi Icon. At that point, I can't access anything.

But after waiting a few minutes, I can access everything just fine again - even though it still shows an X on the Wifi Icon and says 'No Internet' when I pull down the status bar. However, that is only with Mobile Network Data turned OFF or I turn off "Switch to Mobile data when WiFi has no Internet"

So, for some stupid reason, the phone thinks I have no Internet on this Wifi SSID, so it tries over Network Data and fails - so nothing works.

There must be a Ping Test or something for Wifi that is failing and so it reports no Internet and borks everything up.

What the HECK is going on and how do I get this back to a sensible state?

7
  • You should state which versions of Android (8, 9, 10, etc) the devices are running and if the Nexus 9 tablet is running a custom ROM. – Morrison Chang Oct 7 '20 at 2:07
  • Already posted Asus ROG 2 Phone 17.0240.2009.49 (its Android 10, duh) Nexus 9 has last official Android update: 7.1.1 – Da Hai Zhu Oct 7 '20 at 2:28
  • And I assume you've cleared the WiFi access point, turned off the phone, restarted the phone and tried to sign into the WiFi and still gives you the captive portal message. – Morrison Chang Oct 7 '20 at 2:31
  • yes: reset wifi on the phone, forgot the wifi access point, rebooted, reconnected and re-entered wifi password and it still gives the captive portal message. – Da Hai Zhu Oct 7 '20 at 2:47
  • One thing to try is to check the adb logcat logs and see if anything in particular comes up when you try to access your WiFi access point. You'll need to enable developer mode, developer.android.com/studio/debug/dev-options, and see: stackoverflow.com/a/12658349/295004 – Morrison Chang Oct 7 '20 at 2:47
0

After dicking around in ADB with Captive Portal setting, changing URLs and crap, I finally just gave up and set :

adb shell settings put global captive_portal_mode 0

now it doesn't check, doesn't prompt to login to a non-existent portal, or show "No Internet" on the wifi - and the wifi does work.

Don't know WTF was going on, but I wasted an entire day screwing around with this stupid phone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.