0

Samsung Galaxy J7 running Android 8.1.0. Totally vanilla, not rooted or anything like that.

A few days ago suddenly gmail and other google apps stopped working, showing messages like "Gmail won't run without google play services, which are not supported by your device". Have had the phone for years & been using all the usual google apps all the time and this has never happened before.

Looking in settings->apps, Google Play Services is in there, but the Google Play Store is not.

What I have tried:

  • Reset app preferences.
  • Went into google play services under settings->apps and tried to uninstall updates, but it said something like "failed to uninstall updates".
  • Attempted to remove my Google account from the device (thinking I'd add it again afterwards which might reset something) but it asks for my Google password and does not accept the password (which is definitely correct, I can see it and compare directly with the one that works on my computer).

I have not tried a factory reset because I am concerned that if google play services still don't work after the reset, I won't be able to install whatsapp and other apps that I rely on.

Any ideas?

thanks

EDIT: I followed advice in the comments and installed google play services from apkpure. Now, the phone doesn't work at all. I keep getting the message 'com.google.process.gapps keeps stopping' and it prevents me from doing anything at all on the phone.

5
  • Download this.. apkpure.com/apkpure/com.apkpure.aegon/download and try updating play services – Aayush Oct 15 '20 at 4:57
  • @Aayush Sorry but if you post a link to an app please name the app and describe what it does. As anybody can post here links it could be just malware or something other unwanted. – Robert Oct 15 '20 at 6:59
  • It's ApkPure.. Sort of an app market.. trusted.. He thinks he won't be able to install apps after reset cause Play store won't work.......... – Aayush Oct 15 '20 at 16:12
  • @Aayush while version 3.17.19 of APKPure app is considered safe, the previous version has been infected by malware at least once. – Andrew T. May 4 at 11:53
  • @AndrewT. Ohh.. didn't know about that.. btw i currently use aurora store from fdroid.. open sourced. – Aayush May 5 at 15:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.