2

The issue

I installed Lineage OS on my blackview BV 5500 Pro and am facing the "No Service" issue since. There does not seem to be any hardware issue and I've exhausted all the options I could think of.


Specifications


What I've tried

Here's what I've tried:

  • Restarted the phone.
  • Activated the Airplane mode, waited, and de-activated it.
  • Set the values for data and MMS manually, using the carrier's recommendations.
  • Tried to select manually the carrier (more on that below).
  • Checked the sim card in a different phone -- it works.
  • Enabled the cellular data.
  • Allowed roaming.
  • Checked the phone with a different OS (it was working just fine before I flashed the OS).
  • Made sure my sim card was correctly inserted.
  • Called *#06# and checked that my sim had an IMEI / ESN (it does, I actually have two since this phone accepts two sims).
  • Tried the other sim slot.
  • Called *#*#4636#*#* and checked the information about my phone:
    • It does have a IMEI and IMSI,
    • I can ran a ping test,
    • Radio band is set to automatic,
    • Selected GSM / WCDM, LTE only, and other various network types,
  • Re-installed Lineage.
  • Re-installed Lineage with GApps nano.

Possible issues?

Manually select the carrier

When I try to manually select a carrier, I'm faced with cryptic choices ("310830", "311490", "311480", …), and all of them returns an "impossible to connect to this network" error message.

Comparison

I have the same phone with the same carrier at home, but with the stock rom on it (Android 9, build BV5500Pro_E535_V1.0_20191105V6). If I check in *#*#4636#*#*, I can see that the Network Mode is set to LTE / UMTS auto (PRL). However, that choice is not available on my phone.

Baseband?

Between the stock rom and Lineage OS, I've tried another rom (BV5500Pro_EEA_E535_V1.0_20190514V8) to test that I could flash my phone. Could that have messed with the baseband, or something else? My current baseband is E535_39_P0_LWTG_V0.1.4_S190402.

5
  • 1
    Well you are using a modified generic system image (GSI). When trying a GSI I would recommend to use the original one from Google which is AFAIK also used for device compliance tests. In any way if you are not a AOSP developer I would recommend to prefer a device model specific firmware, instead of a GSI. – Robert Oct 16 '20 at 7:02
  • @Robert The reason why I'm trying to get a modified GSI is to have more modularity, because the constructor's rom is quite old (Android 9), and because I generally enjoy fully open-sources projects such as Lineage. Even though I'm not an AOSP developer indeed, I don't see why the GSI can not accommodate my sim card / hardware. I must be missing something. – Clément Oct 16 '20 at 7:18
  • (And, also, since I have access to the constructor's firmware, can't I, in the worst case, extract the pieces I'm interested in?) In any case, thanks for your comment @Robert – Clément Oct 16 '20 at 7:34
  • Based on How to Install Lineage OS 17.1 for Blackview BV5500 Pro | Android 10 GSI treble, there's a disclaimer: "LineageOS 17 GSI build is based on PHH’s AOSP Android 10 GSIs which is still marked as a pre-release. Even on a device that runs Pie GSIs nicely, it’s still possible to get broken media, camera, RIL or even flat-out no-boot. You are strongly advised to try PHH’s original and then identify/report issues there, before moving onto other GSIs that is based on his work. [...]" – Andrew T. Oct 16 '20 at 13:11
  • @AndrewT. Thanks for your comment. I completely forgot about that disclaimer, much needed indeed. – Clément Oct 17 '20 at 4:50
2

Update

So, actually, I've tried to install magisk, which I believe is the culprit.

Following the documentation, since this model does not have Ramdisk memory, I've patched the recovery.img file using their Manager application, and then flashed my recovery partition, using

 fastboot flash recovery /path/to/magisk_patched.img

After rebooting, their application was still not detecting magisk's installation, and my OS could not detect my SIM card anymore. After flashing back the stock recovery, the sim card was back.

This seems to be a fairly common issue, judging by


Original Message

Ok, so I've done the following:

  • Installed the official rom, BV5500Pro_E535_V1.0_20191105V6, that blackview shared directly with me: the sim card was not even recognized!
  • Flashed everything, installed a previous version of lineage (lineage-16.0-20191017-UNOFFICIAL-treble_a64_bvN): sim card still not recognized.
  • Installed another official rom (that they share here, called BV5500Pro_EEA_E535_V1.0_20190514V8): the sim card is back, and I can connect to the network!
  • Re-installed lineage-17.1-20201012-UNOFFICIAL-treble_a64_bvS. The sim card is still detected, and I can now connect to the service!

Needless to say, I have no clue what actually solved my issue. My network is set to GSM / WCLMA / LTE (PRL) and I have not noticed any value or configuration that would have changed…

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.