1

Problem

My phone is stuck in boot loop after suffering water damage. It only reaches the boot loop when I'm charging, otherwise it does not react at all. Edit: I took the battery out and let it and the phone air dry for several days, I don't think there is any moisture left.

Device Info

My phone is a Galaxy S5 Plus/kccat6/SM-G901F and runs lineageos. TWRP is installed. Edit: I have a more or less recent backup saved on my desktop computer.

Backup Info

As per the comments, here are the names of my backup files:

total 4.2G
-rwxr----- 1 nonthevisor nonthevisor   13M Feb 11  2020 boot.emmc.win
-rwxr----- 1 nonthevisor nonthevisor    80 Feb 11  2020 boot.emmc.win.sha2
-rwxr----- 1 nonthevisor nonthevisor  1.6G Feb 11  2020 data.ext4.win000
-rwxr----- 1 nonthevisor nonthevisor    83 Feb 11  2020 data.ext4.win000.sha2
-rwxr----- 1 nonthevisor nonthevisor  909M Feb 11  2020 data.ext4.win001
-rwxr----- 1 nonthevisor nonthevisor    83 Feb 11  2020 data.ext4.win001.sha2
-rwxr----- 1 nonthevisor nonthevisor    66 Feb 11  2020 data.info
-rwxr----- 1 nonthevisor nonthevisor  711M Feb 11  2020 external_sd.f2fs.win
-rwxr----- 1 nonthevisor nonthevisor    64 Feb 11  2020 external_sd.info
-rwxr----- 1 nonthevisor nonthevisor   15M Feb 11  2020 recovery.emmc.win
-rwxr----- 1 nonthevisor nonthevisor    84 Feb 11  2020 recovery.emmc.win.sha2
-rwxr----- 1 nonthevisor nonthevisor  4.1M Feb 11  2020 recovery.log
-rwxr----- 1 nonthevisor nonthevisor 1014M Feb 11  2020 system.ext4.win
-rwxr----- 1 nonthevisor nonthevisor    82 Feb 11  2020 system.ext4.win.sha2
-rwxr----- 1 nonthevisor nonthevisor    65 Feb 11  2020 system.info

What I tried

Here are the things I tried, in the order I tried them. After each attempt, I tried to reboot, the error is still there.

Restore backup from device

  1. boot to recovery mode
  2. select restore
  3. notice that there are no backup files found on the device

Restore backup from pc

  1. boot to recovery mode
  2. connect to pc
  3. try to mount USB-OTP
  4. "unable to mount"

Flash new lineageos image via heimdall

  1. confirm heimdall is running by typing heimdall version
  2. boot phone to download mode
  3. type heimdal print-pit to check if device is found
  4. ERROR: Failed to detect compatible download-mode device.

Install lineageos from recovery via adb

  1. boot phone to recovery mode
  2. select sideload
  3. on host, type adb sideload lineage-16.0-20201022-nightly-kccat6-signed.zip
  4. error: no devices/emulators found

I've read this thread, but since I'm stuck in boot loop I cannot enable USB debugging on the device.

Factory reset

  1. recovery mode
  2. select wipe
  3. wipe
  4. reboot
  5. still boot loop

However, it doesn't ask me for my decryption pattern anymore, so the reset must have been at least partly successful.

17
  • 1
    In your first sentence you already mentioned that your phone has been damaged by water. Why do you think that installing a new firmware would "heal" this damage? – Robert Oct 24 '20 at 18:46
  • just dry the short-circuited buttons – alecxs Oct 24 '20 at 20:22
  • @Robert the reason is that clearly the hardware is still functioning to some degree, seeing as it can boot into recovery or download mode. I just included the information about water damage because 1) it was the event that caused the problem and 2) maybe someone had a similar problem and thus knows the solution – nonthevisor Oct 25 '20 at 11:49
  • @alecxs I forgot to mention it in my question, but I already let the phone dry for several days. I edited that in, thank you for pointing it out – nonthevisor Oct 25 '20 at 11:52
  • @alecxs I do have a backup, and luckily also copied it to my desktop computer – nonthevisor Oct 26 '20 at 12:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.