"Facebook" could not be downloaded due to an error. (495)

How do I solve this error?

Messenger Image

  • Armed with google-fu, and searched yielded this makes me wonder, is your clock out of sync completely, perhaps on the wifi network's router and not your device? – t0mm13b Jul 25 '12 at 16:48
  • For reason unkown to me, I cannot add an answer, so I'll add a comment here then. I faced this same error while trying to update Facebook app, while few other apps updated just fine, while using mobile data. For a time I was wondering why Facebook refused to update, until I did remember that I had prevented several apps from using mobile data. One of them was "Media". After allowing it to use mobile data, Facebook updated just fine. – F-3000 Jun 20 '15 at 10:21
  • There is a helpful official 'Google Play' help page which boils down all the advice here: support.google.com/googleplay/troubleshooter/6332137 I'd post it as an answer but don't have the rep. – EleventhDoctor Jul 10 '17 at 11:26

According to a user on The Transformers' Forum:

"I had the same problem but fixed it. Go to Settings - Apps- All- Download manager and Clear data. Then go to Settings - Apps - All - Google Play Store and Clear cache. Play Store should work and if not try restarting your device."

There is another answer that says that Uninstalling the updates of Google Play app and restarting the device and updating it again solved the issue,

"Uninstall all updates to Google Play, reverting to the original market, then re-starting that, and letting it re-update to Google Play, then re-starting it again."

However vague, clearing the data on Google Play Store app might do the job.

  • 1
    I have tried but same error and my device works with other WIFI networks. – hurelhuyag May 16 '12 at 12:27
  • Wherefore occurs this error? – hurelhuyag May 16 '12 at 12:37
  • Can it be possible that the network you use is blocking downloads (or even the word "facebook") in some way or the other? – SamSPICA May 17 '12 at 9:52

I get this error myself, and it looks like this is mostly a network issue. May be because of some stale values on device, clearing application cache for Google Play or Download Manager can help.

However trying a different network (wifi instead of data) works for me. It might also help if you change DNS addresses on device, I guess.

D/Finsky  ( 4507): [1] DownloadImpl.setState: com.google.android.apps.books from DOWNLOADING to ERROR.
D/Finsky  ( 4507): [1] DownloadQueueImpl.onError:     com.google.android.apps.books: onError 495.
D/Finsky  ( 4507): [1] DownloadQueueImpl.remove: Download    com.google.android.apps.books removed from DownloadQueue
D/Finsky  ( 4507): [1] InstallerTask.cancelCleanup: Cancel running installation of com.google.android.apps.books
E/Finsky  ( 4507): [1] RestoreTracker.onInstallPackageEvent: Restore package com.google.android.apps.books download error 495
I/ElegantRequestDirector( 4507): I/O exception (org.apache.http.NoHttpResponseException) caught when processing request: The target server failed to respond
I/ElegantRequestDirector( 4507): Retrying request

Had the problem on an Alcatel device where "all apps" in settings - apps does not exist. Using WLAN instead of 3g for downloading from Play Store worked. Not sure if it will now also work again on 3g.

Not the answer you're looking for? Browse other questions tagged or ask your own question.