I have a Galaxy Nexus and I live in Belgium (so my phone is not locked to a specific carrier). The Android version is still 4.0.4 and when I go the system update menu, it doesn't do anything, no OTA update. I thought the version 4.1 or even 4.1.1 was available. How can I update it 'officially'?

Of course, I already searched but I only found update packages that I'm not sure I can trust.

  • For official you have to wait.
    – roxan
    Commented May 16, 2012 at 7:41
  • 1
    You may have a device that's configured to receive updates from the carrier rather than from Google directly. You can use an app to check if that's the case. Commented May 16, 2012 at 13:41
  • it's configured to received updates from google
    – Alexis
    Commented May 22, 2012 at 11:14

4 Answers 4


I have the same problem for about half of a year. I've tried entering "checkin" secret code in phone Dialer many times, many weeks in a row, tried to clear data of Google service framework - no luck.

But yesterday I've finally get updated to Android OS 4.1.1! Here is how I did this:

  1. open phone Dialer, enter *#*#2432546#*#* (numbers is representing word "checkin")
  2. wait for message "checkin succeeded" in status bar (you need active internet connection, WiFi or mobile - doesn't matter)
  3. open system Settings -> Apps -> All -> Google Services Framework
  4. click "Force stop" button, wait few seconds
  5. next click "Clear data" button
  6. when open Settings -> About -> System updates. You should see something like "Last checked for update on 1/1/1970"
  7. click "Check now" button
  8. if you didn't receive update yet, repeat this procedure from first step few more times (I've succeeded after second attempt). You could also try to replace step 7 by step 1.

All this sounds very strange for me, but I've tried some separate parts of this sequence many times before and it didn't work. Yesterday I've repeat all 8 step exactly as them written above, two time in a row - and I've finally get Jelly Bean on my Galaxy Nexus (I have yakjuxw firmware).


Two possible reasons:

  1. Your carrier hasn't released the update to their customers yet. Check their support website or call their support to ask.
  2. If you have ever rooted your phone and removed and of the systems applications, which includes bloatware apps like Facebook that come preinstalled, you cannot get OTA updates as your phone's system won't match the update anymore and so it won't install.
  • 4
    p.2 is incorrect, OTA updates come no matter if you have modified your system or not. the only difference is the error message, which appears during the installation. so get can get OTA, just cannot install.
    – lenik
    Commented May 16, 2012 at 15:14
  • @lenik: A distinction without a difference...
    – Logos
    Commented May 16, 2012 at 18:32
  • ok but for me OTA updates don't come at all and I didn't flash or modify my ROM.
    – Alexis
    Commented May 22, 2012 at 11:16
  • @jafar: part 2 of my answer doesn't have anything to do with flashing or modifying your ROM, unless you count removing apps as modifying the ROM.
    – Logos
    Commented May 22, 2012 at 13:11
  • No I don't. I have the stock ROM, not rooted and not modified and independent of any carrier...
    – Alexis
    Commented May 23, 2012 at 8:22

Maybe wait, I had a Nexus One and my phone get OTA three or four month after the Google release, because of my carrier. But you can get the ZIP file of the OTA package and make a manual install. You can find the file on XDA I think.


My phone was a yakju and I don't know why those ones are updated like 2 months after the takju. I had to flash it manually to turn it into a takju and after reboot the update was directly available.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .