1

I installed Lineage OS 17.1 on my Samsung Galaxy S3. Everything worked just fine until I put in my SIM card. The first thing which happened after booting was getting directly asked for the PUK code although I didn't even enter a PIN at all. So I just rebooted the phone again which made it not recognize the SIM card anymore.

After that, I put my SIM card in my Samsung Galaxy S5 with stock ROM and I got the message that my SIM card is permanently blocked.

Any idea what happened there?

8
  • no clue. sounds like lineageos has tried to unlock sim for it's own but i am not aware about such "feature"? – alecxs Oct 31 '20 at 13:04
  • I didn't expect that "feature" at all :D – user335160 Oct 31 '20 at 13:11
  • can you reproduce with another sim card? – alecxs Oct 31 '20 at 13:16
  • I was affraid to put in another working simcard so i put in an old one. It didnt even ask for a pin, just didnt recognize it where as an old iphone asked for a pin after i put it in there. – user335160 Oct 31 '20 at 14:15
  • 1
    @Robert I'm not sure it might be not genuine. I downloaded it from that source: forum.xda-developers.com/galaxy-s3/development/… – user335160 Oct 31 '20 at 14:50
1

You have SIM password. You enter wrong password. Then it ask for PUK code. PUK code is link with sim card.

Use sim on normal mobile. Is it ask PUK code.

You can get PUK code from customer care. You can also get it from your online register account.

Get PUK code and use it. Weather sim card work after it.

1
  • you missed the point OP "didn't even enter a PIN at all" - it is a LineageOS bug (inofficial test build) and will happen again as soon as SIM is inserted – alecxs Jan 15 at 10:22

Not the answer you're looking for? Browse other questions tagged or ask your own question.