1

My phone is stuck in a bootloop and I would like to try to fix it by flashing stock firmware. I used XperiFirm to download firmware. But then in Flashtool it won't load. I tried going to tools -> bundles -> fileset decrypt but it just doesn't load it.

I'm running Windows and noticed a part of Flashtool was detected as a trojan. I made an exception and reinstalled so this shouldn't be a problem.

I tried clicking on the XperiFirm button directly inside Flashtool, but it really quickly flashes and goes away without doing anything (nothing is even added to the log).

I looked into using Newflasher but am wondering if there's a way to save data? I would like to do a dirty flash.

8
  • have you tried Androxyde Flashtool? hardreset.info/devices/sony/sony-xperia-xz1-compact/faq/…
    – alecxs
    Commented Nov 7, 2020 at 10:21
  • @alecxs yes that is the one I mean. I'm unable to do step 3) simply nothing happens. I've tried already but is there an additional step, for example must the phone be connected in a certain mode for XperiFirm to work?
    – JonDon
    Commented Nov 7, 2020 at 10:24
  • ask in support forum Androxyde Flashtool
    – alecxs
    Commented Nov 7, 2020 at 10:39
  • found following instructions: 1) Unzip FTF file, extract the system.sin 2) Dump system image from system.sin with Flashtool -> Advanced-> SIN Editor 3) rename system.ext4 -> system.img
    – alecxs
    Commented Nov 7, 2020 at 11:05
  • I got the stand alone XperiFirm to work. How do I know which version of the firmware to download? I had Pie working so guess it's 47.2 but I don't know what the last 3 characters mean e.g. 47.2.A.11.228-R2C or ` R7C` My country isn't listed under "Market" but I'm planning on going with a customized US or UK.
    – JonDon
    Commented Nov 7, 2020 at 11:27

1 Answer 1

1

I couldn't get the XperiFirm integrated into Flashtool to work. Even with the stand alone, it didn't have the firmware I was looking for. I ended up just Google searching the the firmware with "ftf". Flashing it with Flashtools worked fine.

TL;DR download the desired firmware as an FTF found through a Google Search. Flash it with Flashtool.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .