1

I got my Nokia 3.1 in a bit of a weird situation trying to flash the stock ROM. I feel like it's a lost cause, but since I can still boot in recovery mode, there may still be a solution, I will explain in case someone can help.

It started when I tried to update from Android 8.0 to 10.0 (none of the previous OTA updates had worked and would always reboot in Oreo 8.0). This time, it didn't work and got the phone stuck in a boot loop. The phone is still under warranty, but because I bought it overseas and there's no Nokia care centre here is New Zealand, I had no option but trying to repair it myself.

A wipe/factory reset didn't help, but after changing the active slot from B to A (using fastboot), it booted again in Oreo 8.0. Only problem is that I could no longer start a fresh Oreo 8.0 install without updating first and since all updates failed, I was stuck. I suspect slot B is damaged or corrupt, hence the impossibility to update. To check it, I switched back the active slot to B after a factory reset, and that was not a great idea, the phone wouldn't even boot and looked hard-bricked.

But I still managed to use SP tool to download firmware, so I did that with the original Nokia 3.1 stock ROM (ES2). However, I could not flash all files, I'm not too sure why. I had the error message: ERROR: STATUS_SEC_INSUFFICIENT_BUFFER Verified boot is enabled Please download signed image (sutinfo-verified.img) or disable verified boot

I didn't know how to do either of these, so I skipped the three problematic files: sutinfo.img, systeminfo_a.img, and cda_a.img (not sure what they do?).

It worked and un-bricked the phone, but it now boots to recovery mode only. What puzzles me is that I also no longer have access to fastboot, even when I reboot to bootloader (as if it skipped bootloader and went straight to recovery). I suspect it is because it still boots on slot B but I don't know how I can check that or change it back to slot A without fastboot access. I tried using adb: adb shell getprop ro.boot_suffix but although it can see the device, it failed because it says device is unauthorized. I've tried all the fixes for this I found, to no avail.

So that's where I am, able to boot to recovery (but with adb unauthorized), able to flash firmware (except those files that must be signed), and unable to access fastboot. I'm giving up hope that it's repairable, but I'd love to at least understand what happened, if someone has any idea...

Sorry for the long story...

16
  • Is the device branded by a mobile network operator (MNO)? In this case it is possible that Nokia/HMD Global has used a different signing keys and that your device is therefore locked to firmware mages provided by that MNO. – Robert Nov 10 '20 at 8:57
  • blog.hovatek.com/… – alecxs Nov 10 '20 at 12:58
  • @Robert Thanks, the device is not branded by a MNO here. – ericnz Nov 10 '20 at 20:10
  • @alecxs Thanks for the link, it explains a lot. Hovatek does not have the DA file for the Nokia 3.1, but I will try the one for Nokia 3 (MT6737) and Nokia 2.2 (MT6761) just in case. – ericnz Nov 10 '20 at 20:12
  • @alexcs Regarding entering fastboot mode. I have tried both methods, it used to work but it no longer does. I think at some point, when nothing else worked, I tried for flash with "Format all + Download". This may have caused the problem as 3 files couldn't be flashed because of verified boot... – ericnz Nov 10 '20 at 20:14
1

I had the same problem as you, after looking in a lot of forums I managed to solve it, I hope it helps you. My phone was no longer able to access the recovery, nor fastboot. After trying lots of Rom and various methods, I will explain to you which one I recovered the mobile, that is, losing the Imei, but for that there are many valid solutions. Enter the page https://www.needrom.com/download/nokia-3-1/ You have to create a premium account to download, but they are 3USD for 1 month, download the Rom and the flashtool from that link, when it flashes put it in Firmware Upgrade mode and uncheck the preloader, sutinfo, systeminfo and cda boxes. It worked perfectly for me and after that he let me update via OTA to Android 10. Greetings.

1
  • can you share MTK_AllInOne_DA.bin + auth_sv5.auth + sutinfo-verified.img + boot-verified.img + recovery-verified.img for this device – alecxs Feb 18 at 14:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.