2

I have a Redmi Note 3 (INDIAN VARIANT Kenzo/Snapdragon variant running on Marshmellow 6.0.1 with MIUI Global 10.2) on which I performed an bootloader unlocking procedure via the tool XiaoMiTool V2 from xda since the official method kept denying me for some reason

I also want to let you know that during the procedure i left the oem unlocking option disabled and ran the tool

So after the device's bootloader was unlocked (ss attached)enter image description here enter image description here

I noticed that the OEM unlocking option was still active (meaning I can flip the button and it will just ask for the pass and warn me and enable the option: again ss attached)

enter image description here

enter image description here

So my question is is my device properly unlocked? OR Did I mess up with procedure ? I know i could dial *#*#7378423#*#* (which doesn't work in miui devices) or using fastboot method mentioned here- but the problem is that my device's usb port is damaged in a way that charging works but MTP or any other option doesn't (Yeah I tried multiple usb cables, brought a brand new from official store and multiple devices) or is there any app to do that ?

EDIT : Okay now I tried by adjusting the chord into the port and running fastboot getvar unlocked(ss attached)

enter image description here

Now what does this mean ? Is it still locked ?

I would really thankful if someone can help

12
  • I haven't tried this myself. See if this helps How to Execute ADB Commands over WiFi without USB or Root. according to this site you can connect to your device with adb fastboot via Wi-Fi. Good Luck – Sruly Nov 11 '20 at 21:19
  • this can't work. you can't authorize RSA-key without usb-cable. btw that is adb only, not related to fastboot – alecxs Nov 11 '20 at 22:27
  • As I said I haven't tried but the site claims you can connect. BTW according to that site you can run adb reboot bootloader to boot into fastboot. – Sruly Nov 11 '20 at 22:44
  • I am not sure I understand the question... In most devices (not all) the OEM Unlock toggle becomes unusable once the device is unlocked, in other devices it just does nothing but what you show. Your device is either locked or unlocked, there is no in-between or "properly" unlocked. The OEM Unlocking toggle only says if you can unlock or not, once it the device is unlocked, it does not actually perform any lock/unlock function, and once a device is unlocked it has no function. – acejavelin Nov 11 '20 at 23:12
  • OEM unlocking should affect FRP it will disable FRP as far as it concerns the google play account. but be aware on Xiaomi devices the only way to disable FRP completely is remove MI account from device – alecxs Nov 11 '20 at 23:26
0

It would be good if you enable the Allow OEM unlocking option before proceeding to unlock bootloader
I tried by adjusting the chord into the port and running fastboot getvar unlocked which gave no value meaning the device is still locked (ss attached) enter image description here

Even though it says nothing (unlocked : YES etc), I did switch the toggle on for Allow OEM unlocking before proceeding to flash just to be on a safer side and successfully flashed twrp recovery and carbonrom and the device is running well

1
  • Does this answer your question – or was it rather meant as an additional detail of the question? In the former case I don't get it – in the latter you should rather edit your question and put it there ;) – Izzy Nov 12 '20 at 22:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.