Device: OnePlus7, Android 10

What happened

  • Device was rooted with October security patch updated, custom kernel installed and Magisk Manager hidden (to prevent root detection by an app). All working fine. No problem.

  • Updated Magisk Manager to 8.0.3 successfully but it shows Magisk not installed

enter image description here

  • But device is properly rooted and all rooted apps work fine.

  • I can see the hidden Magisk Manager in app drawer but tapping it doesn't help. Nothing happens. It tries to open, shows Magisk logo and disappears.

  • I can't access the Manager menu to see if I can fix something from there.

What I tried

  • Flashed Magisk again from laptop. No use.

  • Restored stock kernel from backup made by kernel manager app. No use.

  • As suggested by Didgeridoohan's guide tried these

    • Cleared data of Manager. Uninstalled and installed Magisk Manager. No luck.

    • Uninstalled manager, installed canary manager and set channel to update to canary hoping that may help. Doesn't help.

Device still properly rooted

Things to try

  • Flash Magisk uninstall zip and root again.

  • Try manual patching of boot image and flash

  • Dirty flash stock ROM - not possible because device is rooted and would result in boot loop.

  • Any other simpler option?


2 Answers 2

  • install 3rd party app like Link2SD or DevTools

  • get the pkgname for hidden Magisk Manager

  • uninstall hidden Magisk Manager from cmd line

    adb shell cmd package uninstall <pkgname>  
  • reinstall Magisk Manager


Alecxs answer (thanks) led me to a different and easier solution.

I uninstalled the manager and tapped on the hidden manager and it opened up with the correct status! Ridiculously simple.

enter image description here

Note to myself :Remember to unhide Magisk Manager before updating next time

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .