1

So, I used the app "Remote ADB Shell" on my Android phone to grant the WRITE_SECURE_SETTINGS permission to my AndroidTV (HiSense Smart ATV). In order to grant this permission I had to connect my phone to my TV on my network using RSA key authentication.

It has been a while since I did the procedure, however, I believe that I set the IP address of my TV (192.168.0.9) and a port number of my selection (5756). I got a prompt on my TV asking me to allow the RSA key, I pressed accept and was able to send the ADB command necessary.

However, now my TV still listens on port 5756. How can I stop the TV from listening on this port?

  • 1
    It will always listen for adb on that port, unless you go into the developer settings and disable adb over network. This is totally normal and not a security concern. – acejavelin Nov 18 '20 at 20:13
  • Ok, so I assume if a malicious actor were to try to get in to it, an RSA prompt would appear on the TV and I'd only be in trouble if I accepted it? – Pickinanameainteasy Nov 18 '20 at 22:33
  • Yes, that's correct... Note that would require access to your LAN, either wired or wireless. This type of access could not occur from the Internet. It's fairly safe. – acejavelin Nov 19 '20 at 23:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.