I have bought 20 Samsung s6 and after every 4 of them got stuck on Samsung logo, I keep them on charging for 2 days. Nothing work for me.

  • Are you sure the devices are genuine? May be you bought some fake devices that can only show the Samsung logo. Have you tried pressing the power button for 10-60 seconds to force a reboot?
    – Robert
    Nov 24 '20 at 12:20
  • @Robert yes I have tried that, and I bought these devices from authentic manufactures in my country. out of 20 devices 15 are working fine. Nov 24 '20 at 12:26

Since 5 of the Samsung tablets you received are working differently than the other 15 tablets, it's clear that either:

  1. Samsung has sold you a bunch of defective tablets.
  2. You received at least some counterfeit tablets.

In the comments, you mentioned that you believe you purchased them from a reliable source. If they are genuine, your experience indicates Samsung has a quality control issue... perhaps a serious one.

Return the tablets for replacements or insist on a full refund.

Note that I've purchased multiple Samsung Android products with serious problems, and trying to get support from Samsung was time consuming and a huge hassle. I now try to avoid Android devices made by Samsung.


If they're new, I'd return them for an exchange. (And make sure you're not getting cheap fake copies of Samsungs.)

  • Thanks so much, I actually return those tablets back to Samsung, and now they return me back and they are working fine. Nov 26 '20 at 4:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.