2

I have an old Alcatel 1s (5024d) with Android 9 and I wanted to try my hand at rooting it. I've been following a tutorial that's supposed to let me flash a boot.img patched by Magisk Manager.

I've enabled USB debugging and OEM unlocking in the developer options, installed the necessary drivers, and have downloaded the official platform-tools to be able to use adb and fastboot. Additionally, I also have the original cable that came with my phone.

I have zero problems finding my device with and adb with fastboot, but when I try to use fastboot oem unlock (when my phone is in fastboot mode and connected to my PC), it just shows

FAILED (remote: 'unknown cmd.')
fastboot: error: Command failed

I have also tried fastboot flashing unlock, but that shows

FAILED (remote: 'Not implemet.')
fastboot: error: Command failed

There's frustratingly little information about rooting this 1s version, so I'd be grateful for any advice on how to unlock the bootloader.

8
  • Try 1. Changing the cable 2. Port
    – beeshyams
    Nov 25, 2020 at 10:37
  • 1
    @beeshyams I tried that, but nothing changed.
    – filan12
    Nov 25, 2020 at 15:55
  • Try fastboot flashing unlock_critical, some devices need that. Not sure about your device
    – beeshyams
    Nov 25, 2020 at 16:07
  • Above should be after fastboot flashing unlock
    – beeshyams
    Nov 25, 2020 at 16:10
  • See the second last post here forum.xda-developers.com/alcatel-1/help/…
    – beeshyams
    Nov 25, 2020 at 16:12

1 Answer 1

-1

Minimal ADB Fastboot

For Alcatel 1S (5420J), the following commands unlock the bootloader:

adb devices
adb reboot bootloader
fastboot devices
fastboot oem unlock
0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .