2

I am running Android 10 on Realme 2 Pro.

So, I am having a lot of trouble connecting this device via USB for file transfer.

I don't know what's the problem. I have tried enabling and disabling USB debugging.

One thing I recollect is that one day I connected it to a charging brick which it recognised as a USB connection instead of AC and I clicked on file transfer.

Since then and before, I haven't been able to connect my device via USB. One day it connected to somebody's PC and that gave me the idea if the Android can forget previous PC, it might work. Is there any solution?

1

There are two possibilities to forget the connection setting:

USB Charging/MTP

You can change the default behavior your phone uses when connected via USB in the Android settings app.

As far as I know by default there is no entry in the settings list to configure the default USB mode, however if you use the settings search field and search for usb you should get an entry named USB settings

Note that this setting is disabled by default unless your device is connected via USB to a second device (PC, power bank, ...).

Android Debug Bridge (USB debugging)

The option to "forget all PCs" that were authorized to use adb is in the Developer Options right below the entry for enabling/disabling adb. It is called

Revoke USB debugging authorizations

enter image description here

3
  • I did both of those. Still not working. Anything else I can do maybe?
    – Mehul
    Nov 27 '20 at 9:07
  • @Mehul I assume you have already rebooted your device since that time. The only thing left is check the USB cable, may be you are using a defect cable.
    – Robert
    Nov 27 '20 at 9:18
  • I have already rebooted and also tried another USB cable. Is it possible that I damaged my USB port? @Robert
    – Mehul
    Nov 29 '20 at 5:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.