I have 2 pieces of the same device (crackling) and I wanted to clone #1 onto #2. Both are running TWRP 3.4.0.

I ran backup (unencrypted) to SD card on #1. Backup data is stored on the SD card in TWRP/BACKUPS/4400d489/2020-09-03--02-42-32_lineage_crackling-userdebug_9_PQ3A190801002/* (boot.emmc.win, boot.emmc.win.sha2, data.ext4.win000, data.ext4.win000.sha2, ...)

When I run TWRP on #1 again, to test Restore, it says: "Select Package to Restore":

2020-09-03-02-42-32_lineageos_crackling-userdebug_9. [...]

which, upon selection, offers System, Data (excl. storage) and Boot for restoration, as expected.

TWRP on #2 (same SD card inserted) says "Select Package to Restore:"


(it is the parent directory... why?) and then offers no partitions to restore.

What is the problem here (SD card is fine)?


1 Answer 1

  • The number 4400d489 corresponds to the device serial number of Device 1.

  • Since you ruled out problems with SD card, try this. Make a backup of a small partition on the second device on the same card. It will create a folder corresponding to the serial number of device 2. Copy the files from backup of 4400d489 to this folder. I am not sure why in your case this folder was not created but was backed up to TWRP/BACKUP

  • Restore the backup on Device 2 (mount all partitions in TWRP) ,making sure you don't back up boot image from Device 1,as that may have device identifier information. Restoring that would create problems.

  • It's always a good idea to always have a backup stored on your laptop. SD cards can go bad without warning too.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .