1

I'm using a Xiaomi 9 SE phone, with MIUI 12.0.2 (global).

I'm not getting notifications about incoming SMSes! :-(

I tried the general phone settings, under Notifications; the slider toggle for SMSes is enabled, but semi-grayed-out - unlike all other notification toggles.

I tried the SMS app's own notification settings (through the top-right gearwheel menu) - and while that has a bunch of settings, it doesn't seem to have the basic setting for notifying me about incoming SMS messages.

What do I do?

Note: I should stress SMS messages do arrive, and the unread ones are marked as such when I open the SMS app.

5
  • Unlikely but check if SMS app is optimized for battery saving
    – beeshyams
    Nov 30 '20 at 11:02
  • @beeshyams: I don't even see it in the "App battery saver" list of possible apps.
    – einpoklum
    Nov 30 '20 at 11:14
  • Maybe it's an issue with SMS app? try with some other SMS app
    – beeshyams
    Nov 30 '20 at 11:22
  • @beeshyams: I'm using the default, built-in one. Can I even switch it?
    – einpoklum
    Nov 30 '20 at 15:10
  • Why not? Just install any other SMS app like Textra for example. When you are setting it up, it will prompt you to choose it as "default SMS app" from settings. Do that and test
    – beeshyams
    Nov 30 '20 at 15:13
0

I had the same issue. What worked for me was clearing the data of the messages app and initializing it all over again.

1
  • Well, by now - the messaging app started nagging me about switching to Google Message, so I kind of gave it up anyway :-(
    – einpoklum
    Feb 16 at 15:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.