Since ADB debugging is not ON, I keep it off unless I need to do something, I now cant use even Vysor to view whats on screen since my screen died with just some color dots and lines seen on screen. I can only see it in ADB in recovery and funfact - I can still view its files when it connects to computer.

Can anyone tell me how to 'see'the device in regular state via ADB? Like on vysor, I need to see it in adb devices first.

Can I enable USB debugging using adb?

how similar

Now problem is: I get

mount: mounting /dev/block/mmcblk0p24 on /data failed: Device or resource busy

when I try to do the idea listed there,

persist.sys.usb.config, yes done, I even tried ptp and put back there

persist.service.debuggable=1 persist.sys.usb.config=mtp,adb

in /system/build.prop - I dont have this file in system... I have default.prop (I added such lines there then pushed the edited file back) btw having installed TWRP and Magisk. TWRP is my recovery I cant see anything on screen.

Then I try to adb reboot but even if it goes on, empty list of adb devices. I tried making a build.prop with these and pushing it but no change

Is it because the phone goes in lock screen and you cant see the device listed if not unlocked?

Starting TWRP 3.2.3-0-840f04f7 on Sun Dec  6 11:47:42 2020
 (pid 151)
I:Lun file '/sys/devices/f9200000.ssusb/f9200000.dwc3/gadget/lun0/file' does not exist, USB storage mode disabled
I:TW_BRIGHTNESS_PATH := /sys/class/leds/lcd-backlight/brightness
I:Found brightness file at '/sys/class/leds/lcd-backlight/brightness'
I:TWFunc::Set_Brightness: Setting brightness control to 162
I:LANG: en
Starting the UI...
Skipping adf graphics because TW_TARGET_USES_QCOM_BSP := true
cannot find/open a drm device: No such file or directory
fb0 reports (possibly inaccurate):
  vi.bits_per_pixel = 32
  vi.red.offset   =  24   .length =   8
  vi.green.offset =  16   .length =   8
  vi.blue.offset  =   8   .length =   8
double buffered
framebuffer: 3 (540 x 960)
Using fbdev graphics.
I:TWFunc::Set_Brightness: Setting brightness control to 162
I:Loading package: splash (/twres/splash.xml)
I:Load XML directly
I:PageManager::LoadFileToBuffer loading filename: '/twres/splash.xml' directly
I:Checking resolution...
I:Scaling theme width 0.500000x and height 0.500000x, offsets x: 0 y: 0 w: 0 h: 0
I:Loading resources...
I:Loading variables...
I:Loading mouse cursor...
I:Loading pages...
I:Loading page splash
I:Switching packages (splash)
=> Linking mtab
=> Processing /etc/recovery.fstab
I:Reading /etc/recovery.fstab
I:Processing '/cache'
I:Processing '/data'
I:Processing '/system'
I:Processing '/boot'
I:Processing '/recovery'
I:Processing '/firmware'
I:Processing '/efs'
I:Created '/efs' folder.
I:Processing '/persist'
I:Created '/persist' folder.
I:Attempt to load settings from /persist settings file...
I:InfoManager loading from '/persist/.twrps'.
I:TWFunc::Set_Brightness: Setting brightness control to 162
I:TWFunc::Fixup_Time: Pre-fix date and time: 2020-12-06--05-47-43
I:TWFunc::Fixup_Time: Setting time offset from file /sys/class/rtc/rtc0/since_epoch
I:TWFunc::Fixup_Time: Date and time corrected: 2020-12-06--05-47-44
I:Processing '/preload'
  • you can not change default.prop you must 'mount -w /system' and change build.prop also concatenate your rsa_key to /data/misc/adb/adb_keys
    – alecxs
    Dec 2, 2020 at 17:14
  • Ok I try but I said that I get the above error when I try to mount stackoverflow.com/questions/26213954/… (another link I may find useful)
    – programc7r
    Dec 4, 2020 at 16:43
  • Recovery is the only way to use adb but it reboots or exits after 10s so I have that little time to stay on adb before I have renter again for 10s. What's the problem with it? So I have no time to find build.prop but it's not in system. I said that using the mount command I deleted gesture key maybe, to not have a pattern screen but it wont enter adb unless recovery for a while. I added a log of the recovery
    – programc7r
    Dec 6, 2020 at 11:54
  • that recovery.log is far from complete. 10 seconds is very less time for even fully boot recovery. you can use osm0sis' AIK to unpack boot.img, edit default.prop, repack and flash the modified boot.img
    – alecxs
    Dec 6, 2020 at 12:09
  • is TWRP crashing in loop? if only adb is disconnecting every 10 sec it is maybe related to battery fully charged. if TWRP is working otherwise, drain the battery a while, then try again. note the first disconnecting after 30 sec is normal, that's on every TWRP (because of MTP is started) but adb should be stable after adb kill-server and second re-connect
    – alecxs
    Dec 7, 2020 at 7:31


You must log in to answer this question.

Browse other questions tagged .