2

I have an ASUS ZenFone Max Pro (X00T/X00TD)

It is/was discharged and powered off. When i plug it in for charging, it is cycling in start of chaging:

  1. vibration
  2. the icon of empty battery
  3. The bootloader is unlocked... text
  4. the icon of empty battery
  5. empty screen
  6. and then starts again from vibration

I tried to clean the phone's connector, even wiped and stracthed the connector a littlebit, and changed cable, charging source. (One cable is in the 1A charger, another cable is connected to PC.) It doesn't get better.

I tried to leave it in the cycling, i hoped it gets some power.

Does the phone charge always when connected to power, or it just start the charging process after it shows the charging animation (which i don't reach)?

I tried to step in Fastboot mode. It stays in this mode, no cycling.

Does the phone charge in fastboot mode?

I tried to step in Recovery mode.

  1. vibration
  2. powered by android
  3. The bootloader is unlocked... text
  4. powered by android
  5. empty screen and turns off

In fastboot mode i tried to flash stock recovery, and also TWRP and RedWolf recovery. The flashing process works, but i still cannot get in recovery mode, to see something more, maybe about battery or i dont know.

Of course the phone does not turn on. The same as when i try to get in recovery mode.

  1. vibration
  2. powered by android
  3. The bootloader is unlocked... text
  4. powered by android
  5. empty screen and turns off

I did not do anything special nowadays with the phone. Bootloader unlocking and rooting was years ago, nor i did upgrade, so nothing special. I just used the phone, it discharged, and i'm in this state.

What can i do? Is it something with charging, or it has enough power after connected in fastboot mode, but the problem is something with the software?

One more thing: maybe i "pressed" the buttons randomly in my pocket.

Is it possible that in an unlucky situation i got into the recovery mode and pressed something away in recovery menu?

Please help.

edit #1:

Is it possible to turn off the charging screen, charging vibration, screen turning on from fastboot mode? Maybe flash something on or similar? Because then it won't use the slowly charging power.

edit #2:

So the sumary now:

  1. My phone is fully charged.
  2. It does not boot into normal.
  3. It does not boot into recovery, nor by hardware keys, nor by command from fastboot. I tried to flash TWRP, RedWolf and the original recovery too.
  4. Fastboot mode works normally.

Parameters:

D:\Mobil>fastboot getvar all
(bootloader) CPU:SDM636
(bootloader) platform:sdm636
(bootloader) secret-key-opt:*censored*
(bootloader) build-type:user
(bootloader) unlocked:yes
(bootloader) off-mode-charge:1
(bootloader) charger-screen-enabled:1
(bootloader) battery-soc-ok:yes
(bootloader) battery-voltage:4286
(bootloader) version-baseband:       *this is empty, i didn't delete it*
(bootloader) version-bootloader:ZB601KL-0x01-20181019151150
(bootloader) variant:SDM EMMC
(bootloader) partition-type:cache:ext4
(bootloader) partition-size:cache: 0x15E00000
(bootloader) partition-type:userdata:ext4
(bootloader) partition-size:userdata: 0xCEB7FBE00
(bootloader) partition-type:system:ext4
(bootloader) partition-size:system: 0x100000000
(bootloader) secure:yes
(bootloader) serialno:*censored*
(bootloader) product:QC_Reference_Phone
(bootloader) max-download-size:536870912
(bootloader) kernel:uefi
all:
finished. total time: 0.031s

D:\Mobil>fastboot oem device-info
...
(bootloader) Verity mode: true
(bootloader) Device unlocked: true
(bootloader) Device critical unlocked: false
(bootloader) Charger screen enabled: true
(bootloader) Bootloader version: ZB601KL-0x01-20181019151150
OKAY [  0.016s]
finished. total time: 0.016s

But:

D:\Mobil>fastboot boot stock_recovery.img
downloading 'boot.img'...
OKAY [  1.859s]
booting...
FAILED (remote: unknown command)
finished. total time: 1.859s

So booting failed. But i don't know why.

4
  • Comments are not for extended discussion; this conversation has been moved to chat.
    – Firelord
    Dec 7 '20 at 4:02
  • @Firelord, how can we reach chat normally? I mean now i reach chat by your link. But normally how can we start chat?
    – trob
    Dec 7 '20 at 5:24
  • @alecxs, Thank you soooooo much for your help and your time. I learned a lot from you now. You can read the solution below.
    – trob
    Dec 7 '20 at 5:32
  • Go to Android Enthusiasts Chat. Search for a user and invite them in. Create a chat room for them before that. It is all there in the link.
    – Firelord
    Dec 7 '20 at 7:16
2

Believe it or not...

The solution was very stupid.

I cleaned the phone inside, especially the bottom part. Around the connectors, lot of dirt and drying moisture got in. Just enough for - probably - some short circuit.

I don't know why was it okay for fastboot mode, and not okay for recovery and normal boot.

1

Good news!

This gets the voltage of the battery:

fastboot getvar battery-voltage

It says it's 4,32 V. If i remember right, this is around a fully charged battery. So probably it charged up when i left in Fastboot state for some hours. And the cycle/loop meant not that it cannot charge, but rather it does not need to charge.

Bad news! Then what the heck is with my phone?

7
  • 1
    3,85V is the rated voltage, it is written on the battery. (I disassambled the phone.) Charged voltage is higher, discharged voltage is lower.
    – trob
    Dec 6 '20 at 19:20
  • can you figure pin-out? you can charge with some universal cell phone charger like this cgi.ebay.com/152786628220
    – alecxs
    Dec 6 '20 at 19:41
  • Why do i need it? Battery is charged, and phone charges it also in Fastboot.
    – trob
    Dec 6 '20 at 20:05
  • Do you think it writes a wrong number? Is that possible? Hm. I have been trying so long, it should be dead now, if it would not charged. I think.
    – trob
    Dec 6 '20 at 20:39
  • See the origial post's end. I just edited it. It says "boot" command is unkown. And that is very strange.
    – trob
    Dec 6 '20 at 20:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.