2

i try to get gapps working on my avd. I already use a google api image, but anyway the store is missing. Every tutorial tells me to push open gapps via adb: https://medium.com/@dai_shi/installing-google-play-services-on-an-android-studio-emulator-fffceb2c28a1

But i have the problem, that system is not writable. I already tried various solutions like this one: adb push not working on /system, read only

Finally i think this can be the solution: https://stackoverflow.com/questions/49426174/cannot-push-to-android-emulator-because-of-read-only-file-system/49427040

But my problem now is, that the emulator only shows a black screen when i use the -writable-system option. Otherwise it starts fine.

Can someone help me to get the store apk installed on my virtual device?

6
  • do you have any cmd line access while on black screen? i guess -writable-system is requirement (which is according to your linked researches only available API < 28)
    – alecxs
    Dec 5 '20 at 16:51
  • adb says device offline. But it's API 29. So maybe this is the problem
    – Stack
    Dec 5 '20 at 18:11
  • i tried with API 27, it's still the same. Screen remains black emulator @Nokia_8 -writable-system emulator: WARNING: System image is writable Failed to open /qemu.conf, err: 2 Windows Hypervisor Platform accelerator is operational
    – Stack
    Dec 5 '20 at 18:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.