1

This is my first time posting here and I am not sure how to best classify this question with tags, so please excuse me.

Here's the problem: I have backed up the data partition with TWRP and then wiped my Note 10.1 2014 before installing a fresh stock ROM. I did this because it went into a bootloop. When I tried to do a restore of the data partition through TWRP it sent the tablet back into a bootloop, so I had to redo the wipe and installation. I am only really trying to get one thing from the data partition, my S Note notes, so I thought I'd try to do this manually. I unzipped one of the TWRP backup archives (data.ext3.win001 or something like that) and found the folder com.samsung.android.snote in there with the .SPD files inside.

However, the .SPD files actually appear as folders on my Mac, not zip archives as they should be. Something must've gotten mixed up in the TWRP backup. They contain all the appropriate files, and they are of the appropriate size, so I thought I'd zip them on my computer, change the file extension and put them on the SD card and back into the phone to be imported into S Note. However, S Note says "Invalid file format" when I tried to open them.

Does anyone have an idea about how S Note files work, and how they can be correctly zipped, give that I have all the correct contents? I know it's a long shot, but any assistance would be welcome! Cheers!

3
  • Why do you think the .SPD files have to be ZIP archives? If TWRP backup as saved them as folders I would assume this is totally correct. Just upload all the files in the correct directory structure and move them with root permissions to /data/data/com.samsung.android.snote (assuming the SNote data files are located in the app-private directory not somewhere on /sdcard). Adapt the file-system user and group permissions and this should be it. – Robert Dec 7 '20 at 14:28
  • 1
    As an alternative, try Titanium backup for restoring S notes. It has an option to restore from nandroid backup – beeshyams Dec 7 '20 at 14:29
  • language barrier note: can it be that you are using the term "zip" as general synonym for "archive" (for example data.ext3.win001 is not a zip but a tarball archive)? or do you mixing up different file formats (zip archives expected for export/import via sdcard, spd files for internal app data only)? – alecxs Dec 7 '20 at 18:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.