7

Why the virtual keyboard of Android 4.0 has a different qwerty virtual keyboard? It seems the Y is in the wrong place.

Is it some configuration? Where it is?

Screenshot 1 Screenshot 2 Screenshot 3
Screenshots (click images for larger variants)

12

Are the Y and Z keys switched?

It sounds as if you have the wrong language set for your keyboard (or your system, as it defaults to the systems language). Some European keyboard layouts, possibly German, have a QWERTZ layout instead.

Settings > Language & input > Android keyboard (Settings icon) > Input languages

enter image description here

  • Yes, Y instead of Z. So it already are in English (USA) input language as default. I reset the device but without success... – John John Pichler May 21 '12 at 11:57
  • Hhhmm, curious. If it is a QWERTZ layout then there are likely to be several other differences, particularly with punctuation. What are the keys to the right of the L? Also, what exactly does it state as the input language? For instance, it should state "English (US)", not "English (USA)" as you mention. And the language for the device should be stated as "English (United States)". – MrWhite May 21 '12 at 14:21
  • I added the images. – John John Pichler May 21 '12 at 16:47
  • 1
    Ah, I see from the screenshots that you are (were) using the "Samsung keypad" - this isn't the default "Android keyboard" that comes as part of ICS. The "Android keyboard" should also state (directly beneath it) which language it is configured for (which the "Samsung keypad" does not appear to show.) – MrWhite May 21 '12 at 17:40
  • Yes, I think is the Samsung German Layout. I can't replace it, so I installed Hacker's Keyboard from google play. – John John Pichler May 22 '12 at 13:54
2

I solved installing Hackers keyboard of Android Market.

  • I actually use the Hackers keyboard as the default keyboard on my ICS tablet - great keyboard. – MrWhite May 21 '12 at 17:32
  • This is not a solution. BTW, there are many virtual keyboards for ICS. – Android Quesito May 21 '12 at 20:12
2

Had the same problem. Go to Settings -> Applications -> Manage applications -> All -> Your keypad (Samsung Keypad for me). Force stop and then clear data. Solved the issue for me.

1

I had the same issue, and solved it by doing this:

  • Open keyboard and click the settings icon
  • Click input language
  • Uncheck any languages you don't need

This fixed the problem for me.

0

I solved this problem here in the UK by changing language to English(Ireland) keyboard was fine and the mic icon said EN again too not DE which it had changed itself to. After that I changed bk to UK and it was fine too.Weird glitch.

0
  • Open Settings
  • Go to "Locale & Text"
  • Then "Samsung keypad"
  • Then "Input languages"
  • Only tick mark on English US (note: unmark all other languages if it's ticked).
0

Hold the spacebar in and swipe left or right to quickly change languages you have it set to English Canadian atm.

0

I was having the same issue with the W and Z being in the wrong place and was going into the keyboard settings under my phone setting and still was not finding how to fix it. Doing what was suggested here, it did indeed change the letters but I was using Swift keyboard, so when I was changing my phones keyboard, it was not changing the Swift keyboard settings. I finally found a language option within the actual keyboard itself! Ah ha! Once I tapped the language option I found that you can choose from many different layouts on the actual keyboard. This is how I fixed it:

If you're using Swift keyboard, go in like you're sending a new text, from here tap the settings icon (sprocket, found on the top bar of the keyboard), then the sprocket+ icon on the right. You should see the 4 boxes that you can change for the keyboard (Languages, Themes, Typing, Account). Tap languages and then tap the language that you have set up under Your Languages. This will give you the option that you have now, but if you swipe to the left, it will show all of the different options you can choose from. Find QWERTY (or whatever you want to use) and tap on that keyboard. You will see a check mark, showing that you will now use this option. Now go out and try the keyboard again and you will see that your keyboard is what you wanted it at..... then do a happy dance.

protected by Community May 1 at 18:16

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.