I'm having a hard time with my friend's Galaxy Mini which I agreed to flash.

I am a happy owner of S5360,I've flashed using odin before this is not my first try.

Installed and updated kies on a clean install of Windows 7 x64. Windows detects the phone in download mode and installs the required driver. The whole process is the same as with my S5360 phone the difference being the drivers that are installed.

Odin won't recognize Galaxy Mini.

The device currently gets stuck at "Samsung Galaxy Mini GT-S5570l".I can access recovery mode and download mode.

Firmware I'm trying to flash: S5570XWKTN

Odin: 4.42 and 4.43, re-downloaded multiples times from multiple sources thinking it may solve the problem

Additional notes:

I've also tried this on my friends machine which has Windows 7 x86 installed.

Odin never recognized the phone even when it wasn't soft bricked.

At the moment I just want to make it usable.If there is any method can achieve that with or without Odin please reply.

  • How much time have you tried to leave it boot? Commented May 29, 2012 at 20:40

4 Answers 4


The firmwares files you are trying to flash using ODin have bootloaders removed and they are for s5570 while you have s5570i. You should download the firmwares that are specific to your phone from here http://www.sammobile.com/firmware/?page=3&t=1&o=1&m=GT-S5570I&r=1#modelsa1 Hope your problem gets resolved if it isnt till now...


heyy man try odin 1.84 it's good with galaxy mini



If you are stuck on Samsung Logo -> unplug your device from computer -> go in recovery mode -> reset to factory.. and try again installing everything as it should be. Also add your new ROM into your storage, and when you are in recovery mode install the new ROM and everything should be fine


I solved by enabling developer mode and disabling usb debug.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .