So, I was bored and I decided to check some developer options to see what they could do. I found this option called 'smallest width', at first, I set it from 392 to 100 and it automatically set itself to two hundred something, I believe. So, I did the same thing, but this time, I set it to 1000, thinking that it would automatically set itself to the maximum value possible... But it didn't. Right after pressing 'Ok', my screen became so small and a message popped up saying "System is not responding", then my phone restarted to recovery.

Unlike many people who were facing this problem on the internet, my phone's bootloader is unlocked, I have TWRP recovery installed, my phone is rooted and I had USB debugging on. I rebooted to bootloader and tried adb devices, but my phone wasn't there. After that, I booted to TWRP, clicked Mount, checked all boxes (I couldn't check storage), and clicked Mount USB Storage. This time, my phone showed up on the list. Check the image below.

I don't know if it's okay that it's saying recovery instead of device, but I ran adb shell wm density reset and it didn't work. The same with adb shell wm size reset.

As you can see in the image, there was no error, but the phone still didn't want to boot. After that, I tried to check my current screen size and density using adb shell wm size and adb shell wm density, but there was no response.

I also checked the build.prop file in /system and found this line persist.miui.density_v2=440, I changed it to 220, but nothing happened.

Now my question is, why is there no response when I run adb shell wm size/density? It doesn't work in the TWRP terminal as well. Is this command supposed to be in the /sbin directory? Because I couldn't find it there. How can I add it if it is not there? And lastly, if you can suggest any other way to fix my phone that would help me a lot.

  • When booted into TWRP, find your relevant density property in /data/property/persistent_properties and change it there. Use VIM or nano to edit that file. Do not pull it into PC and than push it back.
    – Firelord
    Commented Dec 20, 2020 at 12:43

2 Answers 2


Wipe all data and restart. That's what I did after I made the same mistake of changing the width drastically from 392 to 1000.

It messes with the UI and goes into a loop.


adb reset commands worked for me.

I had USB debugging on. And a few seconds after reboot (after MIUI animation), my device showed in adb devices. Then I used adb shell wm density reset.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .