1

I have a Pixel 3XL on android 10 and a Pixel 3a on android 11. I had previously installed magisk on the Pixel 3a when android 11 was in beta. Recently I found that it had lost root, presumably because android 11 is out of beta and the phone had upgraded to the latest android 11 and was not using the magisk-patched boot image anymore. So, I patched the corresponding boot image for the latest android 11 factory image for pixel 3a, and fastboot flashed it, and it worked.

Unfortunately, I had mixed up my two phones in the fastboot flash step at first, and so then I ended up with the Pixel 3a with android 11 rooted again, but also with the Pixel 3XL stuck on boot, I guess because it had a wrong boot image (for pixel 3a actually) flashed into it. I tried to fix the Pixel 3XL by getting the latest android 10 factory image for it and patching the boot image with magisk. However, after fastboot flash of that patched boot image, it only worked partially. Namely, it could boot, adb shell works, etc., but it no longer responds to touch, so can't be used except for adb shell.

I'm guessing the problem is that I didn't know what was the factory image actually installed on my Pixel 3L, so I just guessed it was the latest, but the boot image from the latest might have some incompatibility with the actual factory image in the phone. I would like to find out what is the actual factory image installed on the Pixel 3L, so I can try to patch the matching boot image.

Hence, my question, how can I know what is the exact version of the android 10 factory image installed on my Pixel 3L? Googling doesn't seem to help, as most pages talk about how to install factory images, not how to find out what is the version installed. In answering my question, please note that I can't interact with the phone now through touch, so cannot check anything under "Settings" with the touch GUI, but can only see the fastboot info (see screenshot below) as well as anything I can access with adb shell (for example, any file in the phone I can check to find out the factory image version installed on the phone?)

fastboot mode screen

8
  • I didn't want to return the device to the factory state, just hoping to flash the appropriate patched boot image (for magisk) without touching the rest of the files. Boot image is only one part of the factory image, if it can be matching with the other files, I don't have to do a full factory reset Dec 21 '20 at 14:36
  • Check the Android security settings for the "Android security patch level". As your system automatically installs updates you should have installed the latest version (Dec 2020). developers.google.com/android/images#crosshatch
    – Robert
    Dec 21 '20 at 14:50
  • @beeshyams Thanks, but I don't quite remember, so was wondering if somebody knew some other way to obtain the info from something like a file I could inspect on the phone. Yes, once I can get the right factory image, I know how to extract the boot image and flash it. Dec 21 '20 at 15:15
  • 1
    Thinking more about it - 1.since you already flashed a boot img and that's not working and you can't access any internals of device, finding out what the version was before is tough if not impossible 2. Why not flash boot images starting (from the time you remember you updated or when you bought the device) and and ending at the version you flashed? . At least one of them has to match //I know it's a tedious and clumsy process but better try than losing data//actually it may be more efficient to go backwards, that is, starting from version you flashed and going one month back at a time
    – beeshyams
    Dec 22 '20 at 6:41
  • 1
    Glad you got that right +1
    – beeshyams
    Dec 27 '20 at 8:52
2

Problem solved, my android 10 phone is working again!

The first crucial observation was that there are something like 18 different different versions of the factory images for Pixel 3 XL for Android 10. However, there is an interesting difference in the naming convention for the first 5 of these factory images, compared to the rest. The first 5 begin with "QP1A" where the rest begin with "QQ1A". See snapshot below for what I mean .. versions of factory image for android 10 for pixel 3 xl

Originally, I had just tried with the most recent factory image, which is QQ3A.200805.001, dated August 2020. Now, the most recent QP.. image, QP1A.191105.003, dated Nov 2019, was emerging as a candidate to try.

The second crucial observation was, looking at the factory image for QQ3A.200805.001, in the same zip file inside it that contains the boot.img, there is also an android-info.txt file, highlighted in blue in the screenshot below. So I was like, "duh .. why don't I see what it says?" location of android-info.txt file

Here is what the android-info.txt says:

require board=crosshatch|blueline

require partition-exists=product

require version-bootloader=b1c1-0.2-6374987

require version-baseband=g845-00107-200409-B-6382632

Now, compare the bootloader and baseband versions here with the versions shown in my fastboot screen (the screenshot posted in my question above). So for this phone, I have bootloader=b1c1-0.2-5672671 and baseband=g845-00048-190722-B-5745561

Unless I misunderstand what "require" means, then "require version-bootloader=b1c1-0.2-6374987" and "require version-baseband=g845-00107-200409-B-6382632" clearly explain why the boot image from QQ3A.200805.001 didn't work as desired. It requires different versions of the bootloader and baseband than I had on my phone.

Excitedly, I checked the android-info.txt from the factory image of QP1A.191105.003, and the versions matched!

require board=crosshatch|blueline

require partition-exists=product

require version-bootloader=b1c1-0.2-5672671

require version-baseband=g845-00048-190722-B-5745561

By the way, I also checked another of the QP.. factory images (QP1A.191005.007, Oct 2019), and the bootloader and baseband versions also matched. Whereas even the earliest of the QQ.. factory images, (QQ1A.191205.008, Dec 2019), didn't match.

Anyway, happy to report that after patching the boot image from QP1A.191105.003, Nov 2019, and flashing it to the phone, touch has been restored and everything appears to be working properly again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.