1

I tried to install Android's ROM and got ERROR 7, then I wiped out cache, data, internal storage, where was twrp.apk installed.
After that I cant get into boot menu (with Install, Wipe... buttons).
Then I copied twrp to the phone:
sudo fastboot flash recovery <twrp.img>
Tried versions 3.2.1-0 and 3.4.0-0, because I heard for certain phone (I have Xiaomi Mi4) it's necessary to use proper version, though I don't know which.

What's going on now: I can successfully can get to the nice splash screen using Volume Down + Power, then on my PC I give sudo fastboot reboot command and press Volume Up + Power and here is the problem: It has no effect, it just keeps rebooting (I see only Xiaomi's logo).

9
  • I would try to directly boot into recovery without flashing: fastboot boot recovery <twrp.img>.
    – Robert
    Dec 27, 2020 at 12:03
  • @Robert error: cannot load 'recovery': No such file or directory. I did Down+power, then waited till fastboot picture appears on the screen and then executed your command with path to twrp.img.
    – R S
    Dec 27, 2020 at 17:10
  • Sorry my fault the recovery was too much. Just execute fastboot boot <twrp.img>.
    – Robert
    Dec 27, 2020 at 17:29
  • 1
    which chipset your Mi 4 have? MSM8939 (ferrari), MSM8974 (cancro), MSM8992 (libra)
    – alecxs
    Jan 6, 2021 at 12:53
  • 1
    flash official TWRP for Xiaomi Mi 3 and keep holding Volume Up while rebooting from fastboot. in TWRP disable dm-verity
    – alecxs
    Jan 7, 2021 at 14:49

0

You must log in to answer this question.

Browse other questions tagged .