2

I tried wiping my old Lenovo tablet using the following methods but none work

Factory reset through the phone

Erase all data using Google's Find my Phone

'wipe data/factory reset' -> 'Yes -- delete all user data' reset using the bootloader

So I installed ADB through android-tools on my latest Manjaro Cinnamon as well as android-udev and tried the following but they don't work either.

$ recovery --wipe_data
/system/bin/sh: recovery: not found
127|shell@android:/ $
$ wipe data
Wiping /data
Error opendir'ing /data 'Permission denied'
Done wiping /data
shell@android:/ $
$ adb shell am broadcast -a android.intent.action.MASTER_CLEAR
Broadcasting: Intent { act=android.intent.action.MASTER_CLEAR }
Broadcast completed: result=0

The device won't load as fastboot nor is there an option to fastboot under recovery or developer tools. So 'adb reboot bootloader' or 'fastboot' devices does nothing either. No root access option in developer tools either. So:

$ su
/system/bin/sh: su: not found
127|shell@android:/ $

and

$ adb root
adbd cannot run as root in production builds
$ rm -rf /data/*
rm failed for -rf, No such file or directory

So I don't know how to proceed and feel like I am out of options. Can someone help me please?

7
  • 1
    your device is in read-only mode because of emmc wear-out
    – alecxs
    Dec 31, 2020 at 9:16
  • @alecxs Okay. Is that a software or a hardware problem? And how do I fix that?
    – Corinthea
    Dec 31, 2020 at 10:33
  • Alright @alecxs. Going through the link you sent and then will try mount and to flash userdata partition. Thank you. Will revert back soon
    – Corinthea
    Dec 31, 2020 at 13:34
  • @alecxs I cant use mount because adb root won't work prior to it. And flashing the partition won't work because the tablet does not have a fastboot mode
    – Corinthea
    Dec 31, 2020 at 13:57

0

You must log in to answer this question.

Browse other questions tagged .