2

I am trying to connect to a Samsung J5 (2016) SM-J510FN, using linux ubuntu 20.04 (libusb-1.0.0), to flash a TWRP image using heimdall v1.4.2 (build from master a2cfdaa)

I have set the udev based on the git repository android-udev-rules

Mobile has USB debbuging on and OEM unlock. And using samsung cables for connection

Mobile phone is visible on lsusb either in normal OS boot or in download mode

Normal Boot:
Bus 001 Device 096: ID 04e8:6860 Samsung Electronics Co., Ltd Galaxy series, misc. (MTP mode)

Download mode / Odin mode:
Bus 001 Device 097: ID 04e8:685d Samsung Electronics Co., Ltd GT-I9100 Phone [Galaxy S II](Download mode)

Running heimdall print-pit works without problems. But then:

heimdall flash --RECOVERY twrp-3.4.0-0-j5nlte.img  --stdout-errors --verbose --no-reboot

Initialising protocol...
ERROR: Failed to receive handshake response. Result: -7
ERROR: Failed to receive handshake response. Result: -7
ERROR: Protocol initialisation failed!

ERROR: Protocol initialisation failed!

Releasing device interface...

My computer only has usb3.0 but also tried with a porthub for usb2.0, this looks like issue #209

Any ideas or tips on how to solve this problem ?!

3
  • try JOdin3
    – alecxs
    Dec 31, 2020 at 14:37
  • Tried JOdin3 but the same issue Jan 17, 2021 at 14:17
  • 1
    then you are left with Odin
    – alecxs
    Jan 17, 2021 at 14:18

0

You must log in to answer this question.

Browse other questions tagged .