I am using Android 11 (Build Number RP1A.201005.004.A1) on a Google Pixel 2 XL with an external BlueTooth keyboard (Logitech K480).

In my normal typing on a desktop or a laptop, I am very used to typing spaces with the Shift key depressed (habit) and it correctly registers as a normal Space key in those environments, but on Android, it triggers a change in language which I have to then stop and change back, and then continue typing.

Obviously, one solution is for me to try and change 20 years of typing muscle memory, but I would also like to know how I can disable this keyboard shortcut, so that I can have a similar typing experience to what I would have on laptop or desktop.


Update (3rd January 2021)

I checked to see if the answers to the question linked in the comments by @Robert solved my issue or not.

As per the suggestions in the linked question, I switched off the Google Indic keyboard which is what was apparently providing the Shift + Space keyboard shortcut, with no way to change this mapping. Here is a screenshot of all the settings in the Google Indic keyboard app, having cycled through all of which, I was unable to locate a setting for changing keyboard shortcuts:


Anyway, reverting to Gboard, which is the main suggestion in the linked question (albeit for Samsung phones) does not resolve my issue:

  1. Firstly, there now appears to be no external keyboard shortcut to switch between languages. I tried several combinations after having added a couple of languages to Gboard.
  2. Secondly, and more importantly, Shift + Space now does nothing. Which means that my original intent of getting Shift + Space to emulate a Space keypress is not actually solved.

In fact, while this query was for my Pixel 2 XL, tinkering around with my Samsung Note 10+, I discovered that the Samsung keyboard actually provides exactly this feature of being able to switch off the Shift + Space external keyboard shortcut to switch languages, which is exactly what I am looking for in Gboard! See the screenshot below (Shift + Space on my Note 10+ now simply enters a Space while typing, exactly as desired):


I am really hoping that someone can help me understand how I can get Shift + Space to be just a plain Space keypress on Android using an external keyboard.

  • 1
    Do you have multiple languages installed so that you could really switch the language or does it simple show a dialog with one possible choice?
    – Robert
    Jan 1, 2021 at 11:47
  • @Robert thanks for your response. Actually, that is a good question. One one of my phones (Samsung Note 10+), since I have only one language installed, this does nothing, other than flash the one language on the screen, and I have no problem ignoring it and typing ahead. However, on the Pixel 2, it auto-toggles between the two installed languages, again without showing me a selector screen. Presumably, with 3+ languages, it would show me a selector screen to cycle through the choices.
    – mornington
    Jan 1, 2021 at 14:28
  • 1
    Does this answer your question? Prevent switching keyboard layout when pressing Shift+Space on an external keyboard
    – Robert
    Jan 1, 2021 at 17:36
  • @Robert thanks for continuing to engage on this query. The linked answer helps, partially. While that query is specific for Samsung phones (mine is the Pixel), switching off the Google Indic keyboard, which is what provides the multiple language support, and falling back to Gboard does "solve" the problem, in that now there is no switching of languages when I press Shift + Space, but I no longer have multiple languages either. I guess the next step now is to figure out how to add another language to Gboard, and to check to see if that re-introduces the problem.
    – mornington
    Jan 1, 2021 at 17:52
  • Hi @Robert I have updated the question based on the suggestions in the question linked by you in the comments. Do let me know if you think I am off-track here.
    – mornington
    Jan 3, 2021 at 14:32

3 Answers 3


Google just posted an update on the ticket for one of the suggested solutions to this issue stating that the next version of Gboard is going to block Shift+Space if any character other than space is hit after pressing the shift key before pressing space. This should eliminate the misfires that cause the complaints about it.


I have a suggestion! You gave me the idea. Install a keyboard called Hacker's Keyboard. Switch to it when you use your Bluetooth keyboard. Hacker's Keyboard doesn't have the shift space function and it will type normally.


go to Settings > General Management > Physical Keyboard > Change Language Shortcut > and disable the short cuts you dont want to use to switch the language.

  • 1
    Note that this only applies to Samsung devices (which is shown on the screenshot on the question), but not necessarily to Pixel devices (which is what the question is about; there's no such menu)
    – Andrew T.
    May 16, 2023 at 12:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .