2

Since recently the phone i have been using for about 2.5 years has developed an issue with it's audio and video codecs. Videos won't play in the Google Chrome app, in the YouTube app, not in Whatsapp or Telegram either. Downloaded videos won't play from the gallery except when i use VLC app (Which is known for having it's own codecs bundled). Audio won't play either, i don't hear a ringtone when i am being called, when i set an alarm for in the morning it goes off but only vibrates (no sound), and music players either don't play the song or skip through all the songs at a fast pace.

I am not debugging something i wrote, this is my phone's system failing on it's own. I tried to unlock the bootloader 2 years ago but never got any kind of special access to the system. I also didn't get any updates on the system since i bought the phone sadly.

I used ADB to get the error logs from me setting an alarm with default ringtone, and it confirms a codec error like i suspected (vorbis codec this time, but other codecs also have the same issue):

[ 01-02 16:07:00.342 13560:13560 E/SoftOMXPlugin ]
unable to dlopen libstagefright_soft_vorbisdec.so: dlopen failed: library "libstagefright_soft_vorbisdec.so" not found

[ 01-02 16:07:00.342 13560:13560 E/OMX      ]
FAILED to allocate omx component 'OMX.google.vorbis.decoder' err=ComponentNotFound(0x80001003)

[ 01-02 16:07:00.342   611: 8727 W/ACodec   ]
Allocating component 'OMX.google.vorbis.decoder' failed, try next one.

[ 01-02 16:07:00.342   611: 8727 E/ACodec   ]
Unable to instantiate a decoder for type 'audio/vorbis' with err 0xfffffffe.

[ 01-02 16:07:00.342   611: 8727 E/ACodec   ]
signalError(omxError 0xfffffffe, internalError -2)

[ 01-02 16:07:00.342   611: 8727 E/MediaCodec ]
Codec reported err 0xfffffffe, actionCode 0, while in state 1

[ 01-02 16:07:00.342   611: 8726 E/NuPlayerDecoder ]
Failed to create audio/vorbis decoder

[ 01-02 16:07:00.342   611: 8722 E/NuPlayer ]
received error(0x80000000) from audio decoder, flushing(0), now shutting down

This goes beyond what i know about Android system, but a full reboot seems to fix the issue temporarily but this is not a good way to make sure your alarm goes off several hours later.. I pasted the full ADB log in a pastebin for those interested.

What can i do except do a hard reset or buy a new phone?

2
  • 2
    You might have a problem with Media Storage. Just for test, find Media Storage on the app list, clear its data, restart the phone. Check of the issue re-occur. – Reddy Lutonadio Jan 2 at 16:20
  • @ReddyLutonadio That sounds like it's worth a try, i did it, i'll let you know in a few days if it worked, thanks – x13 Jan 2 at 16:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.