0

On my Samsung Galaxy Tab S2 running LineageOS 16 with Opengapps, some apps are not being updated to the latest versions. In particular there is Google Meet and Sheets. Meet is stuck on a version dated August 2020 whereas my phone offers a version dated November.

I tried installing Aptoide apk store and it offered updates to both of these apps (and some other too). I installed them and they work, so it is not a question of incompatibility with my system. However, I would like to stick to the Play Store.

Why is this happening? And what could be done to get the latest versions?

5
  • 1
    What happens when you open the page for "Google meet" in PlayStore app? Is an "Update" button available?
    – Robert
    Jan 12 at 13:18
  • No. I tried unistalling and re-installing to no avail.
    – To Do
    Jan 12 at 15:36
  • May be the app has been modified and repackaged and therefore the update is not available. You should check the signature of the downloaded APK if it matches the other Google apps: android.stackexchange.com/questions/9312/…
    – Robert
    Jan 12 at 15:50
  • I installed it from the Play Store and the app is offered by Google LLC. The Store on the tablet shows version 45.0.328626805 whereas on my phone, also running Android 9, it shows version 2020.11.29.345116913.Release
    – To Do
    Jan 12 at 15:58
  • 1
    Different platforms (tablet/smartphone, armv7/arm64) can get different versions of an app. That is nothing unusual on Android.
    – Robert
    Jan 12 at 16:44
0

On Android the app developer can upload different app versions for different platforms.

Therefore it can happen that on your smartphone you have an Google Meet version from Dec. 2020 but on your tablet the latest version is still Aug. 2020.

This can even happen if both device are using the same Android versions. Just the fact that the one device is a tablet and the other a smartphone is enough so that they get different versions of an app.

If you open the page of an app in Google Play Store app and there is no "update" button then you already have installed the latest version that has been released for your current device.

Other criteria that may lead to a different version are:

  • Android version
  • Supported ABI of the CPU and OS (armv7 = 32bit and/or armv8 = 64bit)
  • Screen size
  • Country
  • Mobile network provider
  • Device name
  • Installed libraries (some manufacturer add special libraries that are required for certain apps)
  • Available hardware features such as NFC, fingerprint sensor, ...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.