2

I was running Magisk on Android 11 on my Google Pixel 5. I installed it using a patched boot image from 11.0.0 (RD1A.200810.021.A1, Oct 2020, EU carriers). Today Android 11 prompted me with an update, I installed it without thinking about the consequences. After rebooting Magisk stopped functioning. So I rebooted to fastboot mode and flashed the same patched boot image as i did the first time. I flashed both boot_a and boot_b, I remembered i did that the last time.

After that the phone is stuck in a boot loop.

I also tried flashing the unpatched boot image from the original image, but same effect. Maybe i had to patch the latest magisk version on a fresh boot image, but can't do that anymore without access to magisk on my phone. Was running the latest canary YAHFA version.

Don't know what to do anymore, really hoping there is a solution without loosing all my data.


In the end i fixed it with extracting the boot image from the correct factory image. At first I didn't see that the latest image was at the end of the list here https://developers.google.com/android/images Flashing the boot image gave me a 'no command' screen. But I was able to boot into safe mode. After that i could patch the boot image file with magisk, and patch it in fastboot. And then everything was working again!

9
  • i am afraid by downgrading kernel you might have corrupted your encryption keys. flash all partitions according to your latest version (except userdata) – alecxs Jan 13 at 16:15
  • 1
    see 7. Reroot with Magisk – alecxs Jan 13 at 17:53
  • you write, flash all partitions according to your latest version. you mean the factory image i already downloaded? as far as i can see there is only one factory image available – fr0sty Jan 13 at 21:21
  • there are two. but anyway search for Full OTA Images you can flash from recovery. check current version from 'fastboot getvar ro.build.fingerprint' i think it is this one redfin-ota-rq1a.201205.011-d13beb06.zip – alecxs Jan 13 at 21:53
  • 1
    I got the latest because of the update i did when android prompted me with that. But i fixed it! I was able to boot into safe mode. And from there i patched the boot.img with magisk and flashed it in fastboot. Now everything is working again. Thanks for your help! – fr0sty Jan 14 at 8:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.