0

Somehow I got into a mode where apps selected were intended for deletion . I did not realize that and the camera app got deleted. I have not made any changes since that happened. What can I do to either recover or reinstall the camera app?

This is a Xiaomi Redmi 8A running Android 9. It is not rooted. As far as "how /when did it happen" I do not know more than this: somehow it ended up that ALL applications were selectable with a white round circle and asking "DELETE apps" or something similar. I had never seen that mode before (or since). I tried to get out of that mode but ended up with accepting the Camera that was selected and got deleted.

On and off I do connect Android Studio to the phone - for pushing a simple Ionic app to it. Does Android Studio have some mode that allows bulk deletion of apps on the phone?

7
  • 2
    This cannot happen so easily (camera app being a system app and immune from deletion). Is your device rooted? It would help which Android phone and Android version you have? What were you doing or what app were you using which uninstalled camera app? Is this the same camera app that came with your phone? – Firelord Jan 13 at 21:07
  • @Firelord I updated the question. I do not even know how to root the device. The mystery mode I ended up in (no idea how) was allowing me to select any or all apps of whatever kind for deletion. I tried to get out of that mode without any effect but did not de-select the Camera app apparently. One thing is I have been using Android Studio for pushing a simple Ionic App. Could that have gotten into a strange mode? – WestCoastProjects Jan 14 at 15:20
  • I think you might have entered into Settings -> Apps -> clicked on Uninstall button, and then selected apps. Xiaomi devices come with GetApps app which allows installing apps/bloatware in your device. See if that offers your Camera app. Also, just to be sure have you ensured that Camera app was not disabled. Your device might offer an option to shows disabled apps somewhere. – Firelord Jan 14 at 15:24
  • Thanks : my phone seems to only have PlayStore and not GetApps – WestCoastProjects Jan 14 at 15:28
  • I just what to confirm that Camera app is indeed no longer in your system (that is, it is not disabled either). Can you install this app and search the term camera? This is a FOSS app hosted on a fellow mod's website. apt.izzysoft.de/fdroid/repo/… – Firelord Jan 14 at 15:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.