1

I've successfully compiled Cyanogenmod for milestone a853 and was following these instructions: http://oldwiki.cyanogenmod.org/wiki/Android_SDK_Emulator:_Compile_CyanogenMod_%28Linux%29

and then I run the emulator with this command:

/android/android-sdk-linux/tools/emulator -kernel ./prebuilt/android-arm/kernel/kernel-qemu-armv7

after the ANDROID_ splash screen, the emulator stuck at a black screen without any response. So how can I resolve this problem?

  • I'd be surprised if this works. The drivers and their configuration are most likely going to be incorrect if you've built for the Milestone. – eldarerathis May 22 '12 at 13:32
  • @eldarerathis♦ The code are from android.doshaska.net/cm7 . That's correct I think. I was only following instructions from the url in the question (official cyanogenmod site) – Mickey Shine May 23 '12 at 1:23
  • What I meant was that if your build was configured for the Milestone then that's the only device it's really intended to run on. The emulator doesn't emulate a Milestone, it's a generic set of hardware, so I wouldn't think that a Milestone ROM would necessarily be compatible with the emulator's virtual hardware. I've never tried and I have no idea personally, but that's my assumption. – eldarerathis May 23 '12 at 1:28
  • but, I've successfully run the cyanogenmod for moto dorid on the emulator. so what're the differences? – Mickey Shine May 23 '12 at 3:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.