1

I use Redmi 9 Prime. On that, I use the Truecaller app. I want to use Truecaller only for calls and strictly not for SMS. So I never give SMS read permission to the Treucaller app.

But still, sometimes Truecaller read new personal SMS. Till now did not see any service or OTP SMS in Truecaller. Don't know how come.

What can be the reason or source for getting this possible? How can I stop Truecaller from strictly touching my SMS?

2

2 Answers 2

0

During app installation from Play Store, you may have given permission. Without it, the app will not install. Uninstall and reinstall Truecaller.

Which app is the default SMS app?

Open app / clear cache and storage. Force stop the app. Restart mobile. Again check permission status.

The last option is to start mobile in recovery mode and clear the cache partition.

0

Had the same problem with one of my phones.

I had to do a clean install - i.e. before uninstalling, force kill > clean cache > clear storage and uninstall the app. Then while reinstalling, only provide access to call, call logs, and contacts. When launching, it will ask for SMS permission > deny > and then most important is to select 'never ask again'.

This way, SMS is fully blocked from the intrusive app. It may occasionally ask, but the permission prompt will not come up from Android.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .