2

I was trying to install TWRP recovery to my Infinix X5515F (Smart 2). I followed these steps:

  • enabled OEM unlock and USB debugging
  • connected to a computer
  • logged into adb and sent adb reboot bootloader
  • send fastboot erase recovery
  • flashed this file using fastboot flash recovery <filename.img>
  • tried to boot directly from the image using fastboot boot <filename.img> (after a while without any response, it performed a normal boot to the system, not to recovery)

Then I tried to reboot to recovery by these methods:

  • pressing and holding the Volume Up and Power buttons until the Infinix boot logo appears (after releasing all the buttons it shut down without showing anything, booted again, and performed a normal boot)
  • send adb reboot recovery (it boots to system recovery, not to TWRP)

What is the problem? Is this image corrupt or not right? If it is, can you provide any image for X5515F (not for X5515)?

7
  • what was the output of 'fastboot flash recovery <filename.img>' did it flash successfully?
    – alecxs
    Commented Jan 19, 2021 at 14:08
  • yes it did.and boot command too Commented Jan 19, 2021 at 14:16
  • try PitchBlack Recovery for X5515
    – alecxs
    Commented Jan 19, 2021 at 23:10
  • no i wanted to install a custom rom. Commented Jan 20, 2021 at 2:37
  • will this recovery work for X5515F Commented Jan 20, 2021 at 2:38

1 Answer 1

1

You dont need vbmeta for this device since it is android 8. I searched online and it seems it has mediatek processor. Its been two years now and no one seems to answer here. Please double check if the bootloader is unlocked, this is required for installing custom roms and rooting devices...

Enter the fastboot oem device-info command and run it. It should list some device data, including the bootloader information. Look for Device Unlocked from the info. If it says true next to it, it means that your device is unlocked. If it says false, it means that that it’s still locked.

Once you really confirmed that it was unlocked then you can go and try porting twrp to your stock rom recovery.img. Proceed at your own risk. Please double check the model of the stock rom since it may confuse you and you will end up bricking your phone

You should only tweak the recovery partition of this phone don't touch any other things. If it happens that the device is not opening after flashing wrong recovery.img. You can try mtkclient and use the command python mtk e recovery

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .