1

I tried flashing a custom rom using ADB Sideload in TWRP 3.3.0.0. Now I am unsure how to proceed. I did my preparations:

  • Bootloader is unlocked
  • USB debugging is enabled

However when the sideload froze, after 20-30min I unplugged usb. When I inserted the usb-cable again I tried the following things:

  • when I type adb devices I see my device-id and the status is recovery
  • fastboot devices is not returning my device
  • adb push returns me a couldn't read from device
  • ADB Sideload in TWRP wont work
  • when I trype adb rootI get a msg saying that I already am root

Now I am wondering what to do. When I go into twrp reboot menu I have the options System, Power Off, Recovery and Bootloader. In addition I have the option slot A and slot B. It also tells me that currently I am in Slot B. Here are my questions:

  • How do I reboot TWRP from TWRP? My current guess is to reboot Slot B
    • I also noticed in previous installations that TWRP seems to reboot automatically if no System has been installed.
  • What is the difference between rebooting Slot B and Recovery? Would both reboot in TWRP?
  • Does it make sense to reboot into Bootloader?
    • Do I then need to flash TWRP from fastboot again? Because I am unsure if this would work, as currently my fastboot doesn't find my device

Update: I am using a temporary TWRP booted using fastboot flash boot <twrp-image.img>

8
  • sideload is broken, and obviously you are unsing inofficial build where adb is not proper enabled. fix it in default.prop with AIK
    – alecxs
    Jan 23 at 17:17
  • according to stackoverflow this could also be usb connection issue, but only broad suggestions like changing cable, port, re-installing drivers, use latest platform-tools etc. no really fix
    – alecxs
    Jan 23 at 17:37
  • Got me! I am using an unofficial build. Didnt know that they sometimes dont support adb.
    – 5th
    Jan 23 at 19:47
  • well, it's just always the maintainer who forgot to edit default.prop when porting from stock recovery. but in your case it's different issue as you edited your question
    – alecxs
    Jan 23 at 20:18
  • maybe adb doesnt work with temporary TWRP. However my devices TWRP-Site suggests to adb push the twrp image if twrp is only installed momentarily. I just read: While in sideload mode, regular ADB commands will not work. Based on this I think the reason why I am stuck is that I exited the ADB sideload in TWRP by just pulling the usb cable.
    – 5th
    Jan 24 at 8:52
1

Not sure this counts as an answer. But I prefer to summarise what I learnt from the long comment thread. Note these are lessons learnt from flashing 4 Android Phones in the last 3 months:

  1. Check your usb-cable before starting. If it doesn't connect to the laptop where your adb is installed, get a new one!
  2. If you install want to unofficial builds, try to have at least another alternative ready for installation. Best try to have at least one alternative stable build ready for installation.
  3. Unofficial builds may not support ADB as @alecxs pointed out in the comments
  4. Have an OTG cable ready! I didnt have one ready, but ordered one and left the phone in TWRP for the days until it arrived. With the OTG I managed to install without issues

If 1-4 do not work for you, then I suggest rebooting into bootloader. Thanks @Evan Carroll for the link: Is it possible to boot into a different recovery from TWRP?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.