1

I tried to root my samsung A7 yesterday, I flashed twrp with odin and when I try to install magisk it says "Zip file is corrupt",

I don't have any OS now and I'm left with only twrp.

I flashed twrp again different times with odin but same. I can't boot in fastboot and when I tried with adb sideload my device is not discoverable. I followed all the steps from this video Youtube Video when I tried to root my device.

Is there anyway to bring my samsung back or it's bricked?

Device Model: A750FN

9
  • Flashing TWRP (or Magisk) does not remove the OS. In fact, how can you even flash Magisk if you don't have any OS? What happens when you try to reboot system? Jan 25 at 19:09
  • i recommend to install RMM-State_Bypass_Mesa_v2.zip otherwise you may get permanently locked android.stackexchange.com/q/225021
    – alecxs
    Jan 25 at 20:11
  • @WrichikBasu I meant I don't have an boot image anymore, when I power it off and then try to start it, it goes in recovery mode.
    – G3n1t0
    Jan 25 at 20:52
  • @alecxs first I flashed an file called magisk_patched_boot.rar with odin then I flashed twrp, then I booted in twrp and tried to install magisk but it didn't work, I tried many times and still the error is always the same
    – G3n1t0
    Jan 25 at 20:54
  • @alecxs I tried but I can't cause when I try to install from twrp it shows the invalid zip error for every file I try, not only for magisk
    – G3n1t0
    Jan 25 at 20:55
1

Thanks to @alecxs I was able to fix it. The reason why I was stuck in twrp is because I wiped system through twrp(I was frustrated when I couldn't boot in magisk after many times of trying so I decided to let the System go, the first time trying to root an phone so I didn't know what I was doing).

DON'T WIPE THE SYSTEM!

I still don't know why "Zip file is corrupt" ocurred, maybe because I tried to install magisk through sd card and the sd card was corrupted, or maybe because the twrp I flashed was unofficial, I don't know, but here is how you can recover your phone back:

1.Install the stock rom/firmware for your model at samfw.com,

before you install the stock rom for your phone model you should know your phone CSC(Country Specific Code), if you don't know it just boot in download mode and you will see Carrier ID associated with phone CSC Code

2.Boot in download mode and flash the downloaded rom. If that goes well and now you have your phone back but you still want to root then go to Magisk Installation Guide and follow the instructions.

If you experienced the same error like mine while trying to flash magisk on twrp with sd card then next time instead of sd card try to copy magisk in cache partition and then in twrp flash from there.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.