I'm trying to root my Google Pixel 2 but I can't get the bootloader unlocked.

The phone is a renewed and unlocked international version, model number G011A.

From the bootloader screen, and connected to the computer, this is the result from the following commands:

fastboot flashing unlock

FAILED (remote: 'Flashing Unlock is not allowed') fastboot: error: Command failed

fastboot flashing unlock_critical

FAILED (remote: 'unknown command') fastboot: error: Command failed

It is communicating with the device:

fastboot devices

{{device serial number}}         fastboot

and unlocking the bootloader seems to be enabled on the phone

fastboot flashing get_unlock_ability

(bootloader) get_unlock_ability: 1
OKAY [ 0.000s]
Finished. Total Time: 0.000s

I've tried using a Windows 10 laptop and an Ubuntu laptop, both with the same results. I read that USB ports/cables can be problematic, so I've tried all the USB ports on both laptops using two different cables with the same result.

On the phone itself, developer options are enabled, USB debugging is enabled, and OEM unlocking is enabled. Curiously, OEM unlocking becomes grayed out and disabled after enough failed attempts, but I've been fixing this with a factory reset.

The Android version is 11, build RP1A.201005.004A1

What am I missing here? Why wont this bootloader unlock? Thanks!


1 Answer 1


I just wish I could find someone who figured out a work around. From what I have read Google has intentionally blocked the change of bootloader lock. https://support.google.com/pixelphone/thread/14920605/google-refurbished-pixel-2-is-always-defective-bootloader-unlock?hl=en

  • please note link-only answers are discouraged. As you are the author of that link please copy+paste OP here in addition to your link
    – alecxs
    Sep 20, 2021 at 20:12
  • While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. - From Review
    – Chenmunka
    Sep 21, 2021 at 9:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .